[Samba] Re: Samba problems - looks like a bug in client

Anne Wilson cannewilson at tiscali.co.uk
Fri Jun 10 19:32:43 GMT 2005

On Friday 10 Jun 2005 18:23, Jim C. wrote:
> > at all, saying that access is denied.  Printing from OOWriter is
> It's probably timing out meaning that it is taking so long that OOCalc
> eventually gives up.  This would seem to indicate that it's strictly a
> performance problem of some sort.
Very likely.

> 1. Post the smb.conf for the server.  Use the following procedure:
> testparm > dumpfile.txt[enter][enter].  Edit the file to remove anything
> that isn't relevant and then paste the remainder into a mail message.
	log file = /var/log/samba/log.%m
	smb passwd file = /etc/samba/smbpasswd
	load printers = yes
	name resolve order = hosts lmhosts bcast
	socket options = TCP_NODELAY SO_SNDBUF=8192 SO_RCVBUF=8192
	username level = 8
	deadtime = 30
	map to guest = bad user
	encrypt passwords = yes
	hosts allow = 192.168.0.
	printer admin = @adm
	password level = 8
	dns proxy = no
	netbios name = anne-linux
	printing = cups
	printcap name = cups
	server string = Samba Server %v
	local master = yes
	workgroup = lydgate.net
	printcap name = cups
	security = user
	preferred master = yes
	max log size = 50
	log level = 3
	dos charset = 850
        unix charset = ISO8859-15

   comment = Home Directories
   browseable = yes
   writable = yes
   create mode = 0770
   comment = All Printers
   path = /var/spool/samba
   browseable = no
   guest ok = yes
   writable = no
   printable = yes
   create mode = 0700
   print command = lpr-cups -P %p -o raw %s -r   # using client side printer 

   use client driver = yes

   path = /var/lib/samba/printers
   browseable = yes
   write list = @adm root
   guest ok = yes
   inherit permissions = yes

   path = /var/tmp
   guest ok = No
   printable = Yes
   comment = PDF Generator (only valid users)
   print command = /usr/share/samba/scripts/print-pdf "%s" "%H" "//%L/%u" 
"%m" "%I" "%J" &
    lpq command = /bin/true

   comment = For sharing large files
   path = /public
   browseable = yes
   writable = yes

   comment = Public in Anne's home dir.
   path = /home/anne/Public
   browseable = yes
   writable = yes
   comment = mp3 on Anne's home dir.
   path = /home/anne/mp3
   browseable = yes
   writable = yes

   path = /home/anne/Documents/Spreadsheets
   comment = /home/anne/Documents/Spreadsheets
   public = no
   valid users = anne,david,gillian
   guest ok = no
   writable = yes
#   wide links = no

> 2. Post the client side connection procedure and any errors.
Generally, using Save As > /mnt/homes from an application.  I have also 
tried konqueror's lan browser, but when I select smb as the protocol it 
gives me the login dialogue constantly (appearing to be rejecting the 

> > exceptionally slow, though this is never as bad from any other
> > application.
> Are these other applications using smaller files?
No.  I can print large images from gimp much faster than OOWriter prints a 
text document.

> >>1. Command syntax may have changed on you.
> >
> > Always possible.  My main problem, though, is in saving files across
> > the lan, direct from apps like gnumeric.
> Have you considered using an NFS mount in the short term until you get
> the bugs worked out?  It's easy.  If you like I can show you how.
I had two nfs mount icons on my desktop before I upgraded.  They don't work 
any more either.  Fish, however, works well and for the moment I'm using 
icons with a fish command for convenient mounting.

> > Shorewall is not installed on this (the client) box, and windows boxes
> > can save correctly, indicating that shorewall on the server is working
> > correctly.
> OK, but of course I had to ask.
> >>3. File system permissions on your share directories.  (test by making
> >>it chmod 777)
> >
> > Normally the shared directories are 770, but I have already tested them
> > with 777.
> The trick to trouble shooting is having a process-of-elimination
> procedure.  If we always do our testing with it chmod 777 we know that
> it really can't be a permissions issue.  We also have to concern
> ourselves with the possibility that there might be more than one issue
> as well as the idea that the problems may not be obvious. Since there
> *might* be a permissions issue that we don't understand we make the
> share world writable during testing as a matter of procedure.  If you
> have important files in that directory that you want to safeguard,
> consider creating an empty directory for sharing during the test
> procedure. :-)
There is only one of the shared directories that I would be unhappy about 
having 777.  I can leave that out of the testing.

> >>With nmap you can check both from the same box:
> ...
> > need very specific instructions.
> Do you have nscd running on either of these machines? If not give it a
> try on both.
I haven't met nscd before.  I'll have to check up on that.  I'm snatching 
time out for the moment to answer this, but I'll look at it as soon as I 

> Do you have DNS on your local network?


Registered Linux User No.293302 (http://counter.li.org/)
Have you visited http://twiki.mdklinuxfaq.org yet?  Mandrake at all levels
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.samba.org/archive/samba/attachments/20050610/66041bb0/attachment.bin

More information about the samba mailing list