[Samba] "id" and "id username" don't match up when using Winbind groups

Graeme Humphries graeme.humphries at vcom.com
Fri Jun 10 17:37:47 GMT 2005

On Fri, 2005-06-10 at 07:59 -0500, Gerald (Jerry) Carter wrote:
> Look for differences in the success and failure cases
> from a level 10 winbindd log.

Alright, the big difference I'm noticing is that when I run plain "id",
pretty much nothing shows up in the logs. However, when I run "id
graemehu" (my username), I get the following:

[2005/06/10 11:34:26, 10] nsswitch/winbindd_group.c:fill_grent_mem(187)
  appending someguy at ndx 8
[2005/06/10 11:34:26, 10] nsswitch/winbindd_group.c:fill_grent_mem(215)
  num_mem = 20, len = 171, mem =
[2005/06/10 11:34:26, 10] nsswitch/winbindd_group.c:fill_grent_mem(222)
  fill_grent_mem returning 1

The names correspond to the group I'm having problems with... so it's
like it's just using cached (and incorrect) data when I run "id", but it
goes and retrieves info from winbind every time when I run "id

Any thoughts? My gut feeling is that it's something in how the nsswitch
module is caching user and group info, and when it choose to refresh
that, but I don't really know how to dig deeper into that.


More information about the samba mailing list