[Samba] Unable to authenticate against an OS/2 PDC

Olivier Eymere olivier_eymere at yahoo.com
Wed Jun 1 23:48:17 GMT 2005

In keeping with my theme of OS/2 - Samba (v 3.0.15) authentication issues I
have another issue that I was hoping to get some help with.  What we are
trying to do is have the Samba server authenticate users against an
existing OS/2 PDC.  I believe that I have set everything up correctly
however I am not able to authenticate any users successfully.

First I try to join the domain by running the command:
# net join -U user%pass -S pdc -w wgname -d1
[2005/06/01 19:31:00, 1] rpc_client/cli_pipe.c:cli_nt_session_open(1459)
  cli_nt_session_open: cli_open failed on pipe \PIPE\lsarpc to machine pdc.
Error was ERRDOS - ERRbadpath (Directory invalid.)
[2005/06/01 19:31:00, 0] utils/net_rpc_join.c:net_rpc_join_newstyle(168)
  Error connecting to LSA pipe
Unable to join domain (null).

I am not sure if the concept of "joining" a domain is even valid with OS/2
so I tried to log in anyway and did an iptrace.  What I can see is that
Samba makes a Session Setup AndX Request to the PDC with an anonymous user
(the Account field is empty) and the PDC immediately responds with a Access
denied error (DOS Error 0x01).

I also have a iptrace of an OS/2 client - OS/2 PDC login that is successful
and the Session Setup AndX Request does specify a user in the request.  I
can provide the iptraces and smb.conf files if needed.  Has anyone tried to
configure Samba to use an OS/2 PDC for authentication?  Is it possible?


More information about the samba mailing list