[Samba] A workaround for printer drivers that crash with an exception error after uploading to Samba

Fabio Muzzi liste at kurgan.org
Mon Jul 25 17:01:58 GMT 2005

I  have  just  run  into two printer drivers (Brother 1870N and HP Deskjet
890cxi)  that  seem to crash windows explorer as soon as they are uploaded
to the samba server.

I have tried using "default devmode=yes" with no success for both drivers.

I have found an horrible workaround that maybe should be useful to others,
so I'll describe it here.

First,  uninstall  the  offending  printer  and  remove  the  driver using
rpcclient, like this:

# rpcclient localhost (give password)
rpcclient $> setdriver <printer> <another driver that works>
rpcclient $> deldriverex <driver that does not work>

then  exit rpcclient.

After  this,  install  the  printer's  driver  LOCALLY  on  a  windows PC,
configure  it,  and  share the printer using the same name that is used on

Then, again on Linux, use the command "net rpc printer migrate" to migrate
drivers  and its configuration from the Windows box to the Linux one, like

# net rpc printer migrate drivers "<printer name>" -U Administrator -S <windows machine name>

and then:

# net rpc printer migrate settings "<printer name>" -U Administrator -S <windows machine name>

This  last command returns an error that says: "enumprinterkey failed: DOS
code 0x0000001f, got no key-data" but it still seems to work.

This  has worked for me, and after doing it I was able to use the printers
normally and also modify their settings using a Windows client.

Hope this helps, but I suppose we need a better solution...


  Fabio "Kurgan" Muzzi

More information about the samba mailing list