[Samba] Write list access to Read only share

Tony Gaddis tony_gaddis95 at yahoo.com
Mon Jan 31 17:43:32 GMT 2005

Thanks for the tip.  I tried it for a user/password that was installed in smbpasswd and it worked just like you suggested.
However, I am trying to setup a samba system that can "painless" plug into small workgroup networks.  I want users to be able to access the system without having to set up a username/ password, except for write access to the read only share. (I have another share which is guest ok, guest only for public use). When I tried to access the server from a user/password that was not installed in the smbpasswd file, I get a prompt for a username/password just connecting to the IPC.  So security = user, doesn't seem to work.
I experimented some with Windows sharing and I am not sure that I could setup the Windows shares the way I wanted to setup Samba either.  So my conclusion is that I am not sure that Samba currently can do what I hoped. I am still not sure whether the fact that it doesn't work is a bug or a lack of functionality... I thought this should work based on all of the documentation I have gone through.
A simple version of my smb.conf (with extraneous stuff to this issue stripped out looks like this:
security = share
guest account = smbuser
path = /mnt/win/Share
read only = no
guest ok = yes
guest only = yes
path = /mnt/win/Content
read only = yes
guest ok = yes
write list = ...
Tony Gaddis

remote <remote at leat.ruhr-uni-bochum.de> wrote:
Had a similar problem a few weeks ago. I found out that your config only 
works if you have set security = user in the global section.
Then, a login box should pop up the first time you try to access the share.
For some reason, Windows remembers what you enter in this box, even if you 
don´t check "Remember Username/Password", so be careful with it.

Good Luck,


----- Original Message ----- 
From: "Tony Gaddis" 
Sent: Friday, January 28, 2005 9:47 AM
Subject: [Samba] Write list access to Read only share

>I have been at this problem for almost a week on my own...
> I am running Samba 3.0.4 on a linux 2.4.26 kernel.
> I have a share that I want to be read only to the world and writable by 
> members of the write list:
> [Content]
> path = /mnt/win/Content
> read only = yes
> quest ok = yes
> write list = sam
> I set a password for sam using smbpasswd. I believe all of the UNIX 
> permissions are set correctly.
> I can access the share fine in read only mode. But as user sam on a 
> Windows machine, I try to copy a file to the share and on the first 
> attempt, I get a message "Invalid MS-DOS function". On the second 
> attempt, I get the message "Access is denied".
> By looking at the logs, I see that I get an "NT_STATUS_WRONG_PASSWORD" for 
> sam; since the Windows share password has no value yet, nothing is sent 
> during the session setup. I see that I am connected as the guest user, 
> initially during the session setup and when I try to copy the file. The 
> guest user then gets a "Permission denied" message when open_file is 
> called which makes sense because guest has only read privilege.
> Shouldn't I see a prompt on my Windows system to provide a share password? 
> And then once I provide a share password, I should be connected as sam? 
> (I have another share which is accessible only by a valid user list and 
> that is the behavior when I first try to connect to it).
> Thanks
> Tony Gaddis
> ---------------------------------
> Do you Yahoo!?
> Yahoo! Search presents - Jib Jab's 'Second Term'
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions: https://lists.samba.org/mailman/listinfo/samba

Do you Yahoo!?
 Yahoo! Search presents - Jib Jab's 'Second Term'

More information about the samba mailing list