[Samba] security=share, write / read-only mix doesn't work on Samba3

cknowlton at update.fsix.com cknowlton at update.fsix.com
Sun Jan 30 03:55:34 GMT 2005

> Hash: SHA1
> Carlos Knowlton wrote:
> | I'm having trouble migrating from Samba2 to Samba3.  I'm
> | trying to make  a share that allows some users
> | read-only access, and others read-write.   In version 2.2
> | this worked, but not in version 3.
> |
> | I'm pretty sure it's my configuration, but I ran into
> | this link on the  samba bugzilla site, and now I don't know.
> |
> | https://bugzilla.samba.org/show_bug.cgi?id=1844
> I've always thought this an odd configuration...expecting
> user level access control with a security level that has
> no concept of users.  My recommendation is to migrate to
> security = user.  I'm not really inclined to re-instantiate
> the previous behavior.  It's too confusing IMO (both to
> explain and to maintain).

Well, unfortunately, my users don't have the inclination to migrate from
Win9x (which is what security=share was patterned after, right?) so they
don't have an option to supply a separate username when logging into a
share. So, with security=user, they are required to login to their PCs as
a different user to access shares with users that don't exactly match
their login username.  Is this feature just not supported anymore in

Thanks for the suggestion.

More information about the samba mailing list