[Samba] security=share, write / read-only mix doesn't work on Samba3

Carlos Knowlton cknowlton at mail.fsix.com
Fri Jan 28 22:38:31 GMT 2005


I'm having trouble migrating from Samba2 to Samba3.  I'm trying to make 
a share that allows some users read-only access, and others 
read-write.   In version 2.2 this worked, but not in version 3.

I'm pretty sure it's my configuration, but I ran into this link on the 
samba bugzilla site, and now I don't know.


Can anyone point me in the right direction?

Here's my smb.conf file:


        read raw = yes
        guest account = nobody
        socket options = TCP_NODELAY IPTOS_LOWDELAY SO_SNDBUF=16384 
        wins server =
        null passwords = yes
        map to guest = bad user
        encrypt passwords = yes
        level2 oplocks = yes
        lock directory = /var/lock/subsys
        netbios name = myserver
        write cache size = 16384
        server string = myserver
        min passwd length = 0
        unix password sync = yes
        workgroup = mygroup
        os level = 20
        force user = all
        comment = My Server
        security = user
        getwd cache = yes
        dont descend = /proc,/dev,/etc,/usr
        max log size = 2000
        log level = 1

        comment = My Share
        read list = @CommonUsers
        user = @CommonUsers, at Administrators
        write list = @Administrators
        path = /home/users


Carlos Knowlton

More information about the samba mailing list