[Samba] Visual Studio/Samba Compile from Shares issue

Kevin Wheatley hxpro at cinesite.co.uk
Tue Jan 25 10:22:27 GMT 2005

Jeremy Allison wrote:
> On Mon, Jan 24, 2005 at 02:36:04PM -0500, Kelly S. Smelser wrote:
> > I've run into a problem in which Visual Studio 6.0 gives an Internal
> > Compiler Error message when compiling from a samba share.  The project
> > compiles fine locally and from shares on Windows machines.  To me this
> > suggests that the issue is with Samba.  I've tried adding full access to
> > the share where the project is housed, but to no avail.  Any ideas?  We
> > are running samba 3.0.9-1.3E.2 on a Redhat Enterprise 3 server.  The
> > clients are Windows XP machines running Visual Studio 6.0 w/ SP5.
> Can you get an ethereal trace or level 10 debug log from smbd ?

Have you tried rebuilding from scratch the server hosted project? By
trying to compile locally you efectively started with a clean build I
expect, I've certainly seen issues where the compiler ICEs locally,
but removing all the junk in {Debug|Release} folders fixed it.


| Kevin Wheatley, Cinesite (Europe) Ltd | Nobody thinks this      |
| Senior Technology                     | My employer for certain |
| And Network Systems Architect         | Not even myself         |

More information about the samba mailing list