[Samba] Samba LDAP and add machine script problems

Geoff Scott geoffs at guestshire.com
Thu Jan 20 23:28:44 GMT 2005

> I'm trying to integrate Openldap with Samba version 3.0.10.  I have
> populated
> my LDAP server via smbldap-populate.pl and I've gotten PAM to recognize
> as an authentication mechanism.  Thus, I can add a user with smbldap-
> useradd.pl
> and su to that user.

Can you do a straight login / ssh as that new user?

> The problem I am having is when I attempt to add a computer from MS
> Windoze XP.
> When I attempt to join my domain XP prompts me for a user ID and password.
> If I
> enter a user ID of "root" with either my box's actual root password or the
> password for the LDAP user
> "uid=Administrator,ou=Users,dc=somedomain,dc=org"
> I get the following: "unknown user or bad password".  I suppose this
> makes sense
> because there are only two users in ou=Users (Administrator and nobody)
> neither
> of which is "root".  Alternatively, if I attempt to join the domain
> with a user ID
> of "Administrator" I get "Access is denied".

Somewhere in those howto's and example books that JHT, et al, has written he
says to set the uid of the Administrator to 0.  what UID does your
administrator have?  I believe from vague memory that the smbldap-populate
script automatically sets the uid of the Administrator to 0.  Just use
smbldap-passwd Administrator to make sure that the password is set. then try
adding your Machine again.  This worked for me last night when I got the
same error.

tell us what happens.

Regards Geoff.

More information about the samba mailing list