[Samba] compiling libldap error??

Tim Tyler tyler at beloit.edu
Thu Jan 20 16:35:40 GMT 2005

  Samba experts,
   Ok, we are having so many problems getting ldap to work, we decided to 
start over with our compile.  We are compiling Samba --with-ldap on our AIX 
5.1 system which uses gcc.  Openldap (for client support) exists in 
/usr/local/openldap/2.2.17.   In order for Samba to find the ldap.h file, 
we had to configure with 
CPPFLAGS="-I/usr/local/openldap/2.2.17/include"  which worked great!  Now 
it finds ldap.h with no problem.

    However, now the ./configure gives this error:
configure: error: libldap is needed for LDAP support

   What exactly is it looking for now.?  Is libldap supposed to be a binary 
or library?  We can't find libldap anywhere.  There is a lib directory in 
openldap that contains a bunch of files such as:

# pwd
# dir
total 12560
drwx------   2 root     system          512 Dec 15 13:59 .
drwx------   7 root     system          512 Dec 15 13:59 ..
-rw-r--r--   1 root     system       454117 Dec 15 13:59 liblber.a
-rw-r--r--   1 root     system          646 Dec 15 13:59 liblber.la
-rw-r--r--   1 root     system      2507942 Dec 15 13:59 libldap.a
-rw-r--r--   1 root     system          692 Dec 15 13:59 libldap.la
-rw-r--r--   1 root     system      3442991 Dec 15 13:59 libldap_r.a
-rw-r--r--   1 root     system          698 Dec 15 13:59 libldap_r.la

Is it looking for libldap.a?  Note: we tried to configure with 
LDFLAGS="-L/usr/local/openldap/2.2.17/lib" but that didn't resolve it.  Any 
suggestions for what we may need to do?

Tim Tyler
Network Engineer - Beloit College
tyler at beloit.edu 

More information about the samba mailing list