[Samba] Access denied changing file attributes

Max Bolingbroke batterseapower at hotmail.com
Sat Jan 15 20:14:42 GMT 2005


I've been tearing my hair out trying to get DOS file attributes to work 
with Samba. Basically, I have it all set up so the user mbolingbroke 
(me) can write to this Supernova Backup share I have - this all works 
fine. However, since this is going to backup my Windows machine I want 
to preserve the file attributes. To this end, I've set up mapping of the 
attributess using "map archive = yes" and so on. However, whenever I try 
to change the file attributes using either Windows or the smbclient, I 
get the error: "An error occured applying attributes to the file <file 
name> Access is denied".

I've tried using both extended attributes and the "map * = yes" approach 
to do this - neither has worked. Both extended attributes and ACLs for 
my filesystem are compiled into the kernel, although I removed the ACL I 
had set up from my backup share at one stage trying to get this to work 
and still no joy. The user mbolingbroke is mapped to the NT username of 
"Max Bolingbroke" in smbusers and there is a corresponding entry in 

I'd be really greatful for any insight on this problem! Thanks!

Max Bolingbroke


getfacl output on share:

# file: supernova
# owner: mbolingbroke
# group: users



netbios name = Nebula
server string = An Expanding Cloud Of Vapour
workgroup = BOLINGBROKE

security = user
client ntlmv2 auth = yes
username map = /etc/samba/smbusers

encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd

hosts allow = 192.168.1.

wins server =
name resolve order = wins hosts lmhosts bcase

log file = /var/log/samba/log.%m
max log size = 1024

preserve case = yes
short preserve case = yes

map archive = yes
map hidden = yes
map system = yes

[Supernova Backup]
comment = Supernova backup area
guest ok = no
path = /data/supernova/
public = yes
writeable = yes
create mask = 755

More information about the samba mailing list