[Samba] Re: Unable to connect to smb shares from second machine in workgroup

Andrew DeFaria Andrew at DeFaria.com
Sat Jan 15 04:23:25 GMT 2005

Ed Holden wrote:

> What if you log on as andrew with your Samba password instead of using 
> the long name you have in smbusers?

Not sure what you mean here by "log on". Do you mean to specify "andrew" 
instead of "Andrew DeFaria" to the username portion of the dialog box 
that is presented when I attempt to go to \\earth\share? Tried that 
already. It fails and then leaves username as STARBASE\andrew. First let 
me say that the password for "andrew" on my Linux box is the same as the 
password for "Andrew DeFaria" on both XP boxes. Again, I can connect 
from Voyager as "Andrew DeFaria" - I assume that would really be 
"VOYAGER\Andrew DeFaria". I cannot connect from Starbase as "Andrew 
DeFaria" - I assume that would be "STARBASE\Andrew DeFaria". I've also 
tried "STARBASE\andrew", "UNIVERSE\andrew" and even "EARTH\andrew". 
Nothing works but only from Starbase.

> Yes, it does look like your wireless netwokr is on the same subnet as 
> your wired one, so I'd doubt that the wired test will be successful 
> (but it's probably still worth trying).

Still looking for that long cable.... :-)

Yes I would be worth a try because before Voyager arrived on the scene, 
Starbase stood in it's place and worked just fine.

BTW: my hosts allow was something like "192.168.1. 127.". I changed that 
to specifically allow " 127.". Didn't help. :-(

> Again, I suspect from the login prompt that you are indeed connecting 
> to Earth, but something in the authentication is going amiss.

Exactly. Sorry for my wording of the subject. I can connect - I can't 

> Maybe you should increase the debug level to see what turns up in the 
> logs.

I did that at one time. A lot came out - nothing stood out as the exact 
cause. Perhaps I will try again in a more isolated environment and 
capture the output to post here.

> Also, have you fixed starbase's group policy security settings?

I don't muck with group policy settings. I haven't changed anything.

> There are a couple XP settings for digitally signing and encrypting 
> data, and sometimes they can cause incompatibilities with Samba.  Run 
> gpedit.msc from the Start menu on starbase and the Group Policy editor 
> will pop up.  Navigate through it to Computer Configuration\Windows 
> Settings\Security Settings\Local Policies\Security Options.  Then 
> disable the following policies:
>  Domain Member: Digitally encrypt or sign secure channel data (always)
>  Domain Member: Digitally sign secure channel data (when possible)

Disable them? Or do you mean enable them? Because they are enabled 
already and I thought Samba preferred such things enabled. Besides 
Voyager has them enabled and doesn't have problems. Additionally 
Starbase <-> Voyager can talk to each other WRT SMB shares. Nonetheless 
I tried this and have the same problem.

What do you think about the fact that nmblookup cannot find Starbase but 
can find Voyager? I would think before any authentication could be 
successful Samba would need to be able to locate the machine in question.

More information about the samba mailing list