[Samba] WinXP print problem

John H Terpstra jht at Samba.Org
Thu Jan 13 15:35:14 GMT 2005


I am guessing from the information that you have provided that there may be a 
Samba spool directory permissions problem.

What are the permissions on /var/spool/samba? They should be set to:
drwxrwxrwt which is achieved by:

	chmod 02777 /var/spool/samba

- John T.

On Thursday 13 January 2005 02:32, Jean Lee wrote:
> Hello,
> I am using samba to acces a printer on my Linux server from Windows XP
> Home SP2 clients.
> It was working very well until yesterday evening. Since yesterday, I can
> print from the server (with cups) but I can't print from the Windows
> clients.
> And all the shared folders are still OK. There is only printing from
> Windows clients which doesn't work.
> We changed nothing on the server neither on the client side.
> When I try to print a test page from Windows, I get the following error:
> Unable to create a print task
> I tried the following things :
> Uninstall then reinstall printer from the windows client
> Uninstall then reinstall printer from the server
> reboot the server
> I always have the problem
> Here is a part of my /etc/smb.conf
> [printers]
>     comment = All Printers
>     valid users = user gp pm cm
>     path = /var/spool/samba
>     browseable = no
> # Set public = yes to allow user 'guest account' to print
>     public = no
>     writable = no
>     printable = yes
> I don't know where to search. I tried Ethereal but it is to complex for me.
> Does anybody experienced this problem ? If no, where and what can I
> start to search ?
> THank you for any help,
> Jean Lee

John H Terpstra
Samba-Team Member
Phone: +1 (650) 580-8668

The Official Samba-3 HOWTO & Reference Guide, ISBN: 0131453556
Samba-3 by Example, ISBN: 0131472216
Hardening Linux, ISBN: 0072254971
Other books in production.

More information about the samba mailing list