[Samba] LDAP unable to add Idmap

Adi Nugraha adi at westindo.co.id
Wed Jan 12 04:09:34 GMT 2005

Anyone please ?? really needs help here, if anyone needs to see the log or
anything just let me know.

----- Original Message -----
From: "Adi Nugraha" <adi at westindo.co.id>
To: <samba at samba.org>
Sent: Tuesday, January 11, 2005 4:49 PM
Subject: [Samba] LDAP unable to add Idmap

> Hi,
> I'm trying to setup a Samba with ldap backend, I followed tha samba by
> example chapter 6, followed the instcution in the book, and when it says
> add an idmap data container, LDAP won't allow me to add the idmap
> like this :
> adding new entry "ou=Idmap,dc=test,dc=co,dc=id"
> ldapadd: update failed: ou=Idmap,dc=test,dc=co,dc=id
> ldap_add: Constraint violation (19)
>         additional info: structuralObjectClass: no user modification
> and
> getent passwd | grep Domain returned :
> [root at localhost sbin]# getent passwd | grep Domain
> Administrator:x:0:512:Netbios Domain Administrator:/home/:/bin/false
> at first I thought it was ok, to ignore it as the rest of the validation
> according to the book went fine, but when I tried net rpc join -U
> Administrator%secret it says that the username or password is incorrect, I
> can avoid this by adding a new user with 0 UID and then I can join the
> domain, but I can't login after I joined the domain, "Domain is not
> available" or something, can anyone help me with this, I even tried
> reinstalling everything from scratch ( format the hardrive) this is the
> time already, and I don't know what else I'm missing, Please help me
> thx
> Adi
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list