[Samba] read only share access after upgrade to 3.0.10

Graham Vincent graham at gpv.co.nz
Tue Jan 4 00:50:22 GMT 2005

Hello Samba gurus.

I'm in upgrade hell after upgrading my backup rh9 server and fc2 linux
box to 3.0.10 from 3.0.7. rh9 rpm package was from the samba site and
the fc2 rpms from redhat.

I now have a system where the win xp and win98se machines on the network
can read/write to the backup share but my fc2 box only has read only
access to the share - it could write before the upgrade.

I tried downgrading back to 3.0.7 but the problem is still there - maybe
the upgrade made a change that didn't get undone with a "rpm -Uvh
--oldpackage" downgrade?

I've checked dns name resolution is working OK, tried the sticky bit
suggestion in the Howto (no joy and I didn't need it before anyway) and
upped the log level to try and find what's going on but after 3 days I
have to admit defeat and get some help...

Backup server smb.conf:

# Samba config file created using SWAT
# from hal.gpv.co.nz (
# Date: 2004/05/16 12:12:01

# Global parameters
	workgroup = GPV ENTERPRISES
	server string = Marvin Samba Server
	interfaces = eth0
	min passwd length = 3
	password server =
	username map = /etc/samba/user.map
	log level = 3
	log file = /var/log/samba/log.%m
	max log size = 50
	socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
	hostname lookups = Yes
	dns proxy = No
	ldap ssl = no
	remote announce =
	hosts allow = 192.168.10.,
	hosts deny = 192.168.20.

	comment = Home Directories
	read only = No
	browseable = No

	comment = All Printers
	path = /var/spool/samba
	printable = Yes
	browseable = No

	comment = backup directories
	path = /backup
	write list = @gpv
	read only = No
	create mask = 0770
	directory mask = 0770

If I try smbmount from the fc2 box:

[root at hal gpv]# smbmount //marvin/backup /marvin
(much longer delay here than there used to be...)
Password:<root password>
16155: session setup failed: ERRDOS - ERRnoaccess (Access denied.)
SMB connection failed

or smbclient:

[root at hal gpv]# smbclient -L //marvin -d3
lp_load: refreshing parameters
Initialising global parameters
params.c:pm_process() - Processing configuration file "/etc/samba/smb.conf"
Processing section "[global]"
added interface ip= bcast= nmask=
Client started (version 3.0.10-1.fc2).
Connecting to at port 445
Password:<root password>
Doing spnego session setup (blob length=58)
got OID=1 3 6 1 4 1 311 2 2 10
got principal=NONE
Got challenge flags:
Got NTLMSSP neg_flags=0x608b0215
NTLMSSP: Set final flags:
Got NTLMSSP neg_flags=0x60080215
NTLMSSP Sign/Seal - Initialising with flags:
Got NTLMSSP neg_flags=0x60080215
SPNEGO login failed: Logon failure
session setup failed: NT_STATUS_LOGON_FAILURE

So much for 4 public holidays to start the year off with :-(

All help welcome.



Graham Vincent

More information about the samba mailing list