[Samba] FreeBSD 4.8 / Samba 3.0.11 - more signal 11's thanbefore... (3.0.8) (gdb attempts)

Mitch (WebCob) mitch at webcob.com
Thu Feb 24 23:26:02 GMT 2005

I updated to the current snapshot of kerberos, which resolved an error with
oversided udp auth packets - even the original 3.0.8 server started to show:

/usr/heimdal/bin/kinit mtest at MYDOMAIN
mtest at MYDOMAIN's Password:
kinit: krb5_get_init_creds: Response too big for UDP, retry with TCP

So after updating Kerberos I rebuilt Samba.

I had to change my users.map with entries like:
user15 = MY.FULL.DOMAIN\mitch
user15 = MY.FULL.DOMAIN\mitch MY\mitch

After that, a simple test like:
smbclient -I -U TSDEMO.BITBLOCK.NET\\bitblock-m \\\\slim1\\u100595

works again, but a test from the windows server / domain control we are
working from produces the signal 11's again.

I am NOT using winbind - the config worked fine under 3.0.8...

There is NO core file.

Following the howto notes, I tried to attach to the running process:
root      63049  0.0  0.3  6564 3580  ??  Ss   11:17PM   0:00.02
../sbin/smbd -D
root      63050  0.0  0.3  6564 3580  ??  S    11:17PM   0:00.00
../sbin/smbd -D
I tried:
gdb ../sbin/smb 63049

Trying to connect hung my windows files explorer but produced no usable
output or indication of error...

Tried again with the second process (after killing everything and starting
over of course) and still got no output.

How do I get something that will be more helpful?



> -----Original Message-----
> From: samba-bounces+mitch=webcob.com at lists.samba.org [mailto:samba-
> bounces+mitch=webcob.com at lists.samba.org] On Behalf Of Mitch (WebCob)
> Sent: February 23, 2005 8:03 AM
> To: samba at lists.samba.org
> Subject: [Samba] FreeBSD 4.8 / Samba 3.0.11 - more signal 11's
> thanbefore... (3.0.8)
> The error message is the usual panic error - 3.0.11 and FreeBSD 4.8.
> Samba 3.0.8 ran fine with the same config (admittedly there were a few
> roaming profile sync related crashes, which is why I was upgrading).
> Now however I can't even connect - it crashes immediately, respawns and
> crashes again.
> My Samba server is a domain member of a Win2003 domain controller used for
> roaming profile storage as well as shared network drives.
> It was a production server, so I have to set up a test to do the debug 10
> dumps, but thought I'd ask if there were any ideas while I went to work on
> a
> test environment.
> Thanks!
> m/
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list