[Samba] Unable to alter permissions on Linux client

Mark Cooke markcooke.interweb at gmail.com
Wed Feb 23 02:04:19 GMT 2005


I'm sorry, if this has been asked a 1000 times, but I've been going
through the docs and using google for the past 2 hours and everything
I have tried seems to fail.

I've decided to give samba a go at file serving, as nfs is proving to
be not that reliable., and I would also like to be able to access
certain files on my windows machines.
I'm currently running the following:

Samba 3.0.10-1 on Debian Sarge.

I have created a share on my server (same subnet), and can
successfully mount it, using as the required login user, by passing
the a valid users gid and uid settings through with the mount command
(otherwise all files are owned as root/root).

And I can create and delete all files owned by this user, except I'm
unable to change any permissions on any files  or directories owned by
me, I've tried multiple options for the share on umask, create and
force create settings (these have been altered to stop stop windows
from creating executable text files and to  give all users rw access
in the group users (which is my default group).

Below is the share section from my smb.conf.

    path = /exports/networkShares
    comment = Network Shares
    browseable = yes
    public = yes
    printable = no
    writable = yes
    delete readonly = yes
    hide dot files = no
    case sensitive = yes
    force group = users
    valid users = mark
    directory mode = 0775
    force directory mode = 0775
    create mode = 0664
    force create mode = 0664
    oplocks = False
    level2oplocks = False

Any help would be greatly appreciated.


A fool lies awake at nights, worrying of this and that;
weary is he when morning breaks, and all remains as before.

More information about the samba mailing list