[Samba] Troubles creating machine trust accounts

Jason Self jself at intertechdesign.net
Tue Feb 8 20:53:38 GMT 2005

I have set up several machine trusts with samba and they have worked 
correctly.  However for some reason the last machine accounts I tried to 
make are not working correctly.  Here is what I did to create the trust 

useradd -g machines -d /dev/null -c "ids8" -s /bin/false ids8$
passwd -l ids8$ (it even tells me that I have success)
smbpaswd -a -m ids8

"ids8" of course being the machine name.  So I try to connect my machine 
to the domain and it give me an access denied, it basically is acting 
like it can not create the trust relationship between samba and the 
workstation and not even allowing root to log in.  When I checked the 
smbpasswd file I noticed that all of the successfull accounts had X's 
instead of a password hash, but the machine accounts that I made since 
this problem have actual numbers in the password has column of the entry.

Any help would be greatly appreciated, and I will provide any 
information you think would be usefull in resolving this problem.
Respectfully yours,
Jason Self
Electrical Designer /
Network Administrator
Intertech Design Services, Inc.
Get Firefox <http://getfirefox.com/>Get Thunderbird 

More information about the samba mailing list