[Samba] Basic Samba functionality under SuSE 9.2

Misty Stanley-Jones misty at borkholder.com
Tue Feb 8 16:59:37 GMT 2005

Top-posting only because it's short.  You need to start nmbd on the Linux box.  
Make sure that it is not a local, domain, or preferred master, and that the 
OS level is low (5 or so).


On Tuesday 08 February 2005 11:55 am, Tom Peters wrote:
> I'm trying to get Samba 3.0.9-2.3 to work under Suse 9.2. This my very
> first Linux install and I'm a little at sea here. There are so many things
> that could be wrong I don't know where to start.
> The Windows machine I'm using as a client has TCP/IP, file/printer sharing,
> and Client for MS networks. He can't see the linux machine's ("Tolkien")
> shares, but he can ping him.
> This might be a name services issue because issuing a net command at the
> windows box to enumerate the shares (I think that's net view) of the form
> NET VIEW \\TOLKIEN              results in a timeout and error, but
> NET VIEW \\   results in a correct list of the shares I've
> configured on the box!
> C:\WINDOWS>net view \\
> Shared resources at \\
> Samba 3.0.9-2.3-SUSE
> Share name  Type   Used as  Comment
> -------------------------------------------
> archive     Disk            archived files
> (etc)
> I know the IP addresses look odd, I won't go into the reasons using a class
> B but that's worked properly for years, so that's not the issue. Layer 2
> connectivity is good.
> I'm confused about the firewall on SuSE; it's enabled and maybe it
> shouldn't be. All boxes on this little network are on a switch which goes
> to a router, thence to my DSL modem. I'm not using the SuSE box as a
> gateway, it's just on another switch port like the Windows boxes. The
> firewall has the same interface defined as the inside port and the outside
> port.
> But the YAST GUI for configuring Samba has a checkbox for opening all
> appropriate firewall ports, and I did that. I went back to check and it's
> still checked.
> For grins, I portscanned tolkien. TCP ports open are: 21, 22, 25, 110, 139,
> 445. UDP ports: None.
> I tried this:
> net use k: \\\archive
> It works! Well, almost. It prompts for username and password, and username
> and pw I use to login at the linux box doesn't work. "root" with his
> password works.
> I need to get some permissions issues ironed out later.
> -Tom
> [Philosophy] Man's loneliness is but his fear of life.  --Eugene O'neil
> --... ...--  -.. .  -. ----. --.- --.- -...
> tpeters at nospam.mixcom.com   (remove "nospam") N9QQB (amateur radio)
> "HEY YOU" (loud shouting)  WEB ADDRESS http//www.mixweb.com/tpeters
> 43° 7' 17.2" N by 88° 6' 28.9" W,  Elevation 815',  Grid Square EN53wc
> WAN/LAN/Telcom Analyst, Tech Writer, MCP, Cisco Certified CCNA

More information about the samba mailing list