[Samba] problem mounting Solaris 9 (SPARC) samba shares.

Kelly Harding kelly.harding at ntlworld.com
Sat Dec 10 02:10:23 GMT 2005


I've got an old Dual cpu sparcstation 20 running Solaris 9, which has 
the latest version of Samba from the
CSW packages.

I've configured it as needed to what should be a working setup.

All works fine in terms of accessing and browsing shares etc. I can 
browse the shares in OS X and Windows XP and
under Ubuntu linux on my laptop. but if I try to mount the share on 
either Linux or OS X (10.2)I get an error message.

The error I get is:

8057: session setup failed: ERRDOS - ERRnoaccess (Access denied.)
SMB connection failed

This appears in the logs (dmesg output) when I run the daemons (nmbd/smbd):

Dec 10 02:02:15 morrie nmbd[157]: [ID 702911 daemon.error] [2005/12/10 
02:02:15, 0] nmbd/nmbd.c:(736)
Dec 10 02:02:15 morrie nmbd[157]: [ID 702911 daemon.error]   standard 
input is not a socket, assuming -D option

Am I missing a setting I need to change for permissions on Solaris 
somewhere (I'm not overly familiar with it yet really)?

I've checked the permissions on the share I'm trying to mount and all 
looks fine. yet I still get the error above.

Any suggestions or advice appreciated.



More information about the samba mailing list