[Samba] 3.0.21rc2: Winbindd and "Invalid request size received"

S Clark smc+samba at dogphilosophy.net
Fri Dec 9 01:39:52 GMT 2005

The ongoing saga of The Place We Can't Freakin' Get Samba To Work Even Though 
It Works Everywhere Else...

We're experiencing winbind problems.  Can't authenticate from AD ("Windows 
Server 2003") even though:

"getent passwd" works (shows a list of all users including on AD server).
"getent group" works (shows list of all groups including AD)
"wbinfo -u" works
"wbinfo -n (name-of-AD-user)" works
"wbinfo --user-domgroups=(SID-of-user-derived-from-above-command)" works....

But nobody seems to be able to authenticate.  Windows prompts them for a 
password, then tells them it failed.  (Also - for some reason we still have 
the problem of "getent passwd (user)" not returning anything.  This seems to 
be perversely intermittent.  About an hour ago it was working with the same 
software.  As were windows logins.)

/var/log/samba/log.winbindd shows:

[2005/12/08 19:17:12, 0] nsswitch/winbindd.c:request_len_recv(554)
  request_len_recv: Invalid request size received: 1828

repeatedly for each attempt by windows users to connect now.  I've tried 
restarting smbd, nmbd, winbindd...to no avail.

(The occasionally-but-not-usually-works thing here is actually an ongoing 
problem that at this point I fear will precipitate ripping out of the Samba 
box and overwriting it with "Windows".  I have no idea what the problem is as 
similarly configured samba systems at other locations seem to work just 

This is SLES 9 on a Dell "Xeon" box, using RPM's grabbed from: 

(I also tried the i586 rpm's, just in case.  Same thing.)

Please, I'm begging - can someone tell me what to dig into here?  I'll be 
happy to post configurations, run tests, whatever.  I just don't want to have 
to hear "no, we'll just have to 'buy' Windows because Samba doesn't 
work" (despite all the ones we already HAVE working...it's that kind of place 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 192 bytes
Desc: not available
Url : http://lists.samba.org/archive/samba/attachments/20051208/7f420ed8/attachment.bin

More information about the samba mailing list