[Samba] Printer devmodes

Jeremy Nelson jnelson at canterburyschool.org
Wed Dec 7 23:01:10 GMT 2005

I've been trying unsuccessfully to install an HP Color Inkjet CP1700 
onto my Samba server.  I get the point & print driver loaded just fine, 
but it would appear that I cannot get the devmode reset.  I've tried 
using the "default devmode = Yes" option (and the no option), but that 
doesn't seem to help.

I've followed the specific instructions in the TOSHARG at:


including following steps B1-2, and C1-4 to make sure I'm clicking the 
right buttons, but I'm not getting a second advanced tab as shown in 
instruction C3.  I'm also seeing random "junk" on the general tab in the 
Paper Available text box, which seems to indicate to me that I'm not 
getting the devmode initialized.

I'm definitely logging in as administrator, the print server is joined 
to the domain (the PDC is still a Windows NT 4 box on which the current 
print queue is running), and I've tried it on both Windows XP and 
Windows 2000 clients.  Another slight twist that I doubt matters is that 
I've got 1 netbios alias set up on the Samba server (the main netbios 
name is used for file sharing and the alias for printing, though they're 
both the same machine at the moment).  I've tried accessing as both 
machine names, so I don't think it's that, either.

So I have 2 questions:

1. Where is the devmode stored, and is there any way I can copy a 
working one from an existing Windows server?

2. Does anyone have an idea of something I can do to initialize this driver?

If anyone is so inclined, I've been using the driver on this HP support 


Jeremy Nelson

More information about the samba mailing list