[Samba] Hanging SMBD processes - Samba CRASHING

Matt Lung matt.lung at midwest-tool.com
Wed Dec 7 14:50:28 GMT 2005

Hi folks,

We have been experiencing problems with one of our Samba servers here
for a while now and need a little help.  First off we are running Fedora
Core 3, kernel version 2.6.12-1, and Samba version 3.0.20b. Our hardware
is a RAID 5 DELL PowerEdge 700 server. The problem  I am about to
describe has occurred on this server in previous versions of samba prior
to version 3.0.20b and has the same result every time it happens.

To get to the point of the problem, this server will run fine for a
period of time and then begin to build up SMBD processes until
eventually our users can no longer access shares.  The Samba server just
stops responding.  It does not even respond to STOP, START, or RESTART
commands.  Doing a RESTART on samba will look like it is restarting the
service, but Samba will still be in the same locked state with shares
still not available.  Doing a status on the service then reveals that
the STOP, START, or RESTART did nothing to clear out the old processes
or the locked files it thought it previously had opened.  We end up just
rebooting the server to clear everything out.  Right now we are just
reading through all the documentation, posts, and waiting for this to
happen again to hopefully capture some error in the log.  When that
happens I'll send more detail.

I've seen other posts about this, but none ever clearly state some sort
of resolution to this problem.  So I know this is happening to others.
It's getting increasingly more frustrating since we have been running
samba as our file servers for Windows clients for years now and never
had this much of a problem with it crashing on us like this.  Our
smb.conf file is pretty basic and really it is the one we have run since
we first started.  Since we have not had a problem in the past this is
making me think it is more an external application, like one of our
databases possibly that is causing the SMBD process to build out of
control.  We are open to any and all suggestions to help fix this from
happening anymore.

smb.conf file:

        workgroup = XXX
        server string = Samba Server
        security = DOMAIN
        log file = /var/log/samba/log
        max log size = 100000
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        dns proxy = No
        ldap ssl = no
        log level = 5
        load printers = No
        kernel oplocks = No

        comment = Home Directories
        read only = No
        browseable = No
        available = No

#       comment = All Printers
#       path = /var/spool/samba
#       printable = Yes
#       browseable = No

        comment = Public Data Repository
        path = /var/local/group_shares/public_data
        read only = No
        create mask = 02775
        force create mode = 02775
        directory mask = 02775
        force directory mode = 02775

        comment = Production Control Repository
        path = /var/local/group_shares/prod_control
        read only = No
        create mask = 02775
        force create mode = 02775
        directory mask = 02775
        force directory mode = 02775

Matt Lung

Midwest Tool & Die, Corp.

More information about the samba mailing list