[Samba] Problems with group memberships in AD

Svend Sorensen ssorensen at gmail.com
Thu Aug 18 17:10:28 GMT 2005

I have a Samba box joined to a Windows 2003 AD.  I have noticed a
strange problem with adding users to groups.  I added user 'shw' to
the group 'project1' on the AD.  When the user logs in the the Samba
box, he does not have the permissions of someone in the 'project1'
group.  When I run 'id shw', group 'project1' shows up.  However when
I run 'id' as shw2, group 'project1' does not show up.  For example:

# getent group project1

# su - shw -c id shw
uid=15013(shw) gid=15000(domain users) groups=15000(domain

# su - shw -c id
uid=15013(shw) gid=15000(domain users) groups=15000(domain users)

# wbinfo -r shw

I have restarted the winbindd daemon several times.  Has anyone seen
this behavior before?  Any know fixes?

Samba 3.0.14a on Slackware 10.0

workgroup = SOLARSYSTEM
netbiosname = earth
realm = solarsystem.us
security = ads
password server = sun.solarsystem.us
idmap uid = 15000-20000
idmap gid = 15000-20000
winbind user default domain = yes
template shell = /bin/bash

More information about the samba mailing list