[Samba] Windows can't see my Samba shares...

Vincente Aggrippino vaggrippino at gmail.com
Mon Aug 8 14:01:21 GMT 2005

Ok... I'm really stumped.  I have checked thoroughly.  I've performed
all of the steps in the checklist from the HowTo... except for the
nmblookup parts.  The arguments to nmblookup seem to be based on an
old version.  I'm hoping someone will have an idea.  Here's the whole

Fedora Core 3
Linux myserver 2.6.11-1.35_FC3 #1 Mon Jun 13 00:52:08 EDT 2005 i686
i686 i386 GNU/Linux
Samba v3.0.14a latest Fedora RPM available downloaded from samba.org today
Microsoft Windows XP Professional, Service Pack 2
Firewall disabled
Workgroup name: HOME
# Samba config file created using SWAT
# from (
# Date: 2005/08/08 14:03:44

# Global parameters
    workgroup = HOME
    server string = home.aggrippino.com
    security = SHARE
    guest account = testsmb
    username map = /etc/samba/smbusers
    log file = /var/log/samba/%m.log
    hosts allow = 192.168.1.

    comment = temporary files
    path = /tmp
    guest ok = Yes

    read only = No
    guest ok = Yes
I created a new user named testsmb on both the server and the client
for the purpose of testing this setup.  The password is the same.
On the client, if I try to "View Workgroup Computers", there is a long
delay, then it tells me the following:

Home is not accessible.  You might not have permission to use this
network resource.  Contact the administrator of this server to find
out if you have access permissions.

The list of servers for this workgroup is not currently available.
I have the server host resolution in the WinXP hosts file.

Ping works perfectly from the client to the server.
I have the client host resolution in /etc/hosts.

Ping works perfectly from the server to the client.
>From the command prompt on the client, the command "net view \\home"
returns the following after a long delay.  I have the same result when
I use the IP address.  I get the same result if I try to use a
specific resource.  i.e.: "net use x: \\home\tmp" ...

System error 53 has occurred.

The network path was not found.
On the server, I have issued the command "smbpasswd -a testsmb" and
typed the same password as used by the Linux user ID and by the WinXP
user ID.  I've also issued the command "smbpasswd -e testsmb".  I've
stopped and re-started the samba daemons.  I've rebooted the client.
I know it's not my gateway/firewall/router because because I also use
a vmware virtual machine with WinXP Pro and some shares.  The shares
from the virtual machine on the same physical server are normal on the
client.  Incidentally, the virtual machine can't see the server's
shares either.  However, vmware employs some version of samba
internally and that works perfectly between the server and the VM.

I don't run ipchains or iptables.

I must be configuring something wrong.  vmware uses Samba for it's
sharing and that works fine.  The network is working fine.  Otherwise
the VMs shares wouldn't be available.

I'll be very grateful to anyone with a solution.

Thank you,
    Vince Aggrippino
    vaggrippino at gmail.com

More information about the samba mailing list