[Samba] root passwd not working anymore

John H Terpstra jht at Samba.Org
Mon Apr 25 06:09:58 GMT 2005

On Sunday 24 April 2005 23:11, Adi Nugraha wrote:
> Hi,
> since nobody answered my previous post I'm hoping to get an answer for this
> one, I have a working samba PDC with LDAP backend, recently i tried to add
> a W2k Workstation to the domain using root account and it returned with a
> wrong password, but i am able to login using the same account to the
> server, I've tried changing the password to join the doain and it worked
> again, but I'd like to know what made the password unable to join machines
> to the domain anymore, here is the level 10 log from the machine that
> failed to join with the old password

Check the validity of the current 'root' account by executing:

	pdbedit -Lv root

Check if your password is expired.

If necessary, renew your password with:

	smbpasswd root

- John T.
John H Terpstra
Samba-Team Member
Phone: +1 (650) 580-8668

The Official Samba-3 HOWTO & Reference Guide, ISBN: 0131453556
Samba-3 by Example, ISBN: 0131472216
Hardening Linux, ISBN: 0072254971
Other books in production.

More information about the samba mailing list