[Samba] Can't Install Samba 3.0.14a

Guido Lorenzutti guido at lorenzutti.com.ar
Tue Apr 19 03:44:17 GMT 2005

FC3 uses rpm packages to mantain the system up to date.

Im sorry to tell you that Fedora dosen't work this way, you just can't 
upgrade every single package coz every package needs a dependency. FC 
doesn't resolve this automatically.

You should download every samba-*-3.0.14a-1.i386.rpm and install them to 
make this work. When you download every package, just

rpm -Uvh samba*3.0.14a*rpm

And everything maybe... maybe... works. But again, is Fedora...

This is not a samba problem. Is a Fedora problem.

E Hines wrote:
> I'm running FC3 with its bundled samba 3.0.11-fc3, and I'm trying to 
> update to 3.0.14a.  I've downloaded the rpms from samba.org, and (I 
> think) I've backed up the original samba installation--/etc/samba--and 
> I've stopped smb (I had to kill the smbd and nmbd processes; 
> "/etc/rc.d/init.d/smb stop" didn't work).  I've also withdrawn (make 
> uninstall) an earlier abortive attempt to install 3.0.14a from source.
> However, when I run rpm -U samba-common-3.0.14a-1.i386.rpm (for 
> instance), I just get:
>    error: Failed dependencies:
>            samba-common = 0:3.0.8 is needed by (installed)
>    samba-3.0.8-0.pre1.3.i386
>            samba-common = 0:3.0.8 is needed by (installed)
>    samba-client-3.0.8-0.pre1.3.i38
> I also get a Warning V3 DSA signature: NOKEY, but I think this is 
> relatively minor.
> When I tried the -i switch, I got a long-ish list of conflicts with the 
> 3.0.8 installation (no surprise there, I suppose).
> What am I doing wrong?
> Thanks for your help.
> Eric Hines

More information about the samba mailing list