[Samba] still ACL bug in 3.0.14a

Tom Schaefer tom at umsl.edu
Mon Apr 18 17:41:06 GMT 2005

Hi Peter,

Bad news at this end too.  Peter, Jeremy put out a patch over the
weekend, if you browse back through this thread a little bit you should
find it.  He actually posted it twice as I recall.  Perhaps the patch
would fix things for you.  It fixed things for at least the one person,
Eric Stewart, who was having the same troubles as we are of being able
to create & modify files but not delete or rename them.  Although from
the way I read Eric's postings, although he was having the same error as
us in the end, to me he seemed to be doing things quite differently to get
there.  Like in the beginning when he was having the problem, I don't
even think he was using ACLs at all.  Then it came out that
compiling --with-acl-support might fix things for us.  Eric specifically
went back and remounted his file system with ACL support and recompiled
Samba with ACL support but in the example file listings he posted it
still didn't look like he was actually making any use of ACLs whatsoever. 
But he was having the same symptoms.  Jeremy wrote a patch and it fixed it
for him.  He was doing a force group which apparently was the root of his
ills.  Which worries me a bit because I do a lot of force group on my
actual servers.  In this testing mode I've been in since Friday I've
just been keeping things as basic and simple as possible.  I did get it to
work on Linux by compiling --with-acl-support but I was not doing any
force groups or anything the least bit exotic.  

I have yet to get it work properly on Solaris.  I'm in the process of
putting together a level 10 debug log and anything else I think
might be useful for him and sending it off to Jeremy.  Jeremy had
suggested that the patch he wrote for Eric might fix my trouble on Solaris
as well.  It did not.  I noticed there is a new message in this thread
posted from Yannick Bergeron stating he applied the patch and rebuilt
3.0.14a from scratch this morning and the problem persists for him as

Tom Schaefer

On Mon, 18 Apr 2005 11:35:12 -0500
"Peter Kruse" <pk at q-leap.com> wrote:

> Hello,
> bad news, my problem is not fixed with 3.0.14a
> Jeremy Allison wrote:
> > On Sat, Apr 16, 2005 at 08:29:31PM -0500, Schaefer Jr, Thomas R.
> > wrote:
> > 
> >> I'm modifying what I wrote this morning.  Compiling
> >> --with-acl-support DOES fix the problem on Linux.  Jeremy is right.
> >> Although I had compiled it that way this morning I was accidentally
> >> running one of my earlier compiles.  Sorry.
> > 
> > 
> > I have email access now, but not much of a test environment yet.
> > 
> > This happens a *lot*. People, if you reconfigure and try again and it
> > still doesn't seem to fix the problem please try and ensure that
> > you're running your new binaries. This seems to be a common failure.
> > 
> > 
> I double and triple checked, I am running 3.0.14a and it's the
> binary, made a debian package and installed that which also removes the
> old 3.0.13 installation.
> And also checked that --with-acl-support is used on configure, this
> is included in the debian/rules Makefile.
> Stopped all nmbd, winbind and smbd instances and ran the 3.0.14a
> binaries it says in the logfiles:
> log.nmbd:  Netbios nameserver version 3.0.14a-Debian started.
> log.smbd:  smbd version 3.0.14a-Debian started.
> So it is 3.0.14a and the bug is still there.  Exactly the same
> as described in https://bugzilla.samba.org/show_bug.cgi?id=2619
> If you create a file with the mentioned acls do you have
> a different behaviour?
> 	Peter

More information about the samba mailing list