[Samba] still ACL bug in 3.0.14a

Stewart, Eric eric at lib.usf.edu
Sun Apr 17 03:42:33 GMT 2005

	If someone has this working on Red Hat Enterprise Linux 3, I'd
like a few pointers.
	I've changed "defaults" in /etc/fstab for the affected partition
to "defaults,acl,user_xattr" and rebooted the box.  I've gone so far as
to make sure all processes were killed, remove the samba sbin, bin, lib,
and include directories, checked to make sure ACL support is being
compiled in (ldd even shows libacl.so.1 linked).  I've even gotten
desperate and and added "delete readonly = yes" and even "nt acl support
= no" (in all sorts of combinations) to the junk share in the config
below, and yet I still get access denied when attempting to delete a
file.  ls -laF shows:

: ls -laF /usr/local/samba/junk
total 5608
drwxrwxr-x    2 bb       mysql        4096 Apr 16 00:44 ./
drwxr-xr-x   11 root     root         4096 Apr 16 23:20 ../
-rwxrw-r--    1 LIB+eric mysql       46080 Mar 31  2000
-rwxrw-r--    1 LIB+eric mysql     5668947 Mar 25 09:11

	With the "force group =" set, anyone who qualifies as a valid
user should be able to delete the file.  But I can't.

   load printers = no
   guest account = nobody
   hosts allow = 131.247.112., 131.247.113.
   workgroup = LIB
   security = domain
   password server = *
   client schannel = no
   encrypt passwords = yes
   local master = no
   os level = 1
   wins server =
   server string = LIB208 Samba Test
   preserve case = yes
   invalid users = root mail daemon
   log level = 10
   debug uid = yes
   debug pid = yes
   log file = /usr/local/samba/var/log.%m
   lock directory = /usr/local/samba/var/locks
   share modes = yes
   allow trusted domains = no
   winbind separator = +
   winbind uid = 12500-19999
   winbind gid = 12500-19999
   winbind enum users = yes
   winbind enum groups = yes
   winbind use default domain = no
   template homedir = /dev/null

   comment = junk test
   browseable = yes
   force create mode = 0664
   force directory mode = 0775
   force group = mysql
   follow symlinks = no
   path = /usr/local/samba/junk
   valid users = @LIB+Technology
   read only = no

> -----Original Message-----
> From: samba-bounces+eric=lib.usf.edu at lists.samba.org 
> [mailto:samba-bounces+eric=lib.usf.edu at lists.samba.org] On 
> Behalf Of Jeremy Allison
> Sent: Saturday, April 16, 2005 9:59 PM
> To: Schaefer Jr, Thomas R.
> Cc: samba at lists.samba.org; Jeremy Allison
> Subject: Re: [Samba] still ACL bug in 3.0.14a
> On Sat, Apr 16, 2005 at 08:29:31PM -0500, Schaefer Jr, Thomas 
> R. wrote:
> > I'm modifying what I wrote this morning.  Compiling 
> --with-acl-support DOES fix the problem on Linux.  Jeremy is 
> right.  Although I had compiled it that way this morning I 
> was accidentally running one of my earlier compiles.  Sorry.
> I have email access now, but not much of a test environment yet.
> This happens a *lot*. People, if you reconfigure and try 
> again and it still doesn't seem to fix the problem please try 
> and ensure that you're running your new binaries. This seems 
> to be a common failure.
> > Unfortunately for me, the fact that I've got it functioning 
> properly on Linux is worthless to me.  All my servers are 
> Solaris / sparc.  The Linux thing was just an exercise to see 
> if it could be narrowed to a Solaris specific problem.  At 
> this moment, for me, it is a Solaris specific problem as I 
> have yet to get it to function properly on Solaris.  I'm 
> hoping the concensus here isn't that I now need to go talk to 
> Sun Microsystems because somehow I'm guessing that avenue 
> isn't going to get me very far.
> Debug level 10 log from Solaris please.
> Jeremy

More information about the samba mailing list