[Samba] Can really anyone help ?

CIKALA Fr é d é ric ROSI/SIPROD frederic.cikala at francetelecom.com
Wed Apr 6 14:37:53 GMT 2005

ok, lets go on in english
(I precise that i'm quite a newbie with linux ...^^ but i want to learn)
So i d not exactly know what is the use of these files ...

So, here is my smb.conf :
workgroup = AD
server string = Samba Server //(a SAmba Server ?? why, im just a client ...)
printcap name = /etc/printcap
load printers = yes
cups options = raw
log file = /var/log/samba/%m.log
max log size = 50
security = ads
encrypt passwords = yes
smb passwd file = /etc/smbpasswd
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
dns proxy = no
idmap uid = 16777216-33554431
   idmap gid = 16777216-33554431
   template shell = /bin/false
   winbind use default domain = no
   comment = Home Directories
   browseable = no
   comment = All Printers
   path = /var/spool/samba
   browseable = no
   guest ok = no
   writable = no
   printable = yes

Now, Here is the nsswitch.conf :

passwd:     files
shadow:     files
group:      files
#hosts:     db files nisplus nis dns
hosts:      files dns
bootparams: nisplus [NOTFOUND=return] files
ethers:     files
netmasks:   files
networks:   files
protocols:  files
rpc:        files
services:   files
netgroup:   files
publickey:  nisplus
automount:  files
aliases:    files nisplus

In fact, the only thing i did is to create the user who i want to join then mount the remote share ...
but i cannot even join ...

for information, when i type winbind here is what i got (nothing)
[root at pcp423960pcs dl]# winbindd
[root at pcp423960pcs dl]#

Thank you for helping me because i'm such in trouble with this problem :
I've told everyones of my new job that linux is The Solution (comparing to NT4 + easyPhp) ... and it doesn't work (yet ;))

-----Message d'origine-----
De : Joris De Pooter [mailto:joris.de.pooter at atempo.com]
Envoyé : mercredi 6 avril 2005 16:29
Objet : Re: [Samba] Can really anyone help ?

Oui, je parle français :p

Mais on peut continuer en anglais, pour que tout le monde en profite ;)

So, first can you provide us your smb.conf ?
Next, my first guess is samba can't find your AD controller.
Have you set up the nsswitch.conf with winbind ?

CIKALA Frédéric ROSI/SIPROD a écrit :

>Apparement, tu parles français, et c'est tant mieux =)
>Effectivement, il apparrait qu'a franceTélécom, il faut d'abord que la machine qui veuille accéder a ces ressources soit d'abord dans le domaine concerné (ici AD)
>Alors je n'ai pas le mot de passe administrateur du filer, cependant j'ai un login/password (non admin) qui me permet (en tout cas sous windauze) d'accéder comme il faut aux fichiers .. mais lorsque je tente le net join ... là, cest le drame :
>[root at pcp423960pcs dl]# net join AD -U sero7472
>sero7472's password:
>[2005/04/06 16:02:09, 0] utils/net_ads.c:ads_startup(186)
>  ads_connect: No such file or directory
>Unable to find a suitable server
>Unable to find a suitable server
>[root at pcp423960pcs dl]#
>je ne comprend pas ces erreurs ... et toi ?
>Merci ^^
>-----Message d'origine-----
>De : Joris De Pooter [mailto:joris.de.pooter at atempo.com]
>Envoyé : mercredi 6 avril 2005 16:00
>Cc : samba at lists.samba.org
>Objet : Re: [Samba] Can really anyone help ?
>Hello / Salut,
>That's odd indeed.
>Just an idea,
>maybe you should try to join the domain first using :
># net join AD -Uadministrator
>and then mount the share.
>Hope this help !
>CIKALA Frédéric ROSI/SIPROD a écrit :
>>I know that it is the right way to use this ML but as nobody answered me, i repost this help ...
>>in fact, it is quite hurry, and i want to understand ...
>>Why do the mount -t smbfs just halfWork ?? can see some directories, but see no file ! :o ...
>>Hello everyone,
>>I'm having such a strange problem and i hope you'll understand the situation.
>>I want to access files that are shared by a Windows server, from a linux box, by using a login/pwd.
>>To be sure that these login/pwd has the good rights, i tested it.
>>>From a windows box (which is in the same active Directory domain of the file server -which is "AD") i tried to mount the remote HD whith the login/pwd, and everything is ok.
>>it works fine
>>But when i use the mount command (from my linux Fedora box #mount -t smbfs ...) i get somme errors but in my /mnt/partage, i can see directories. I also can get trought these, but i cannot see any file .... quite strange isn't it. look :
>>[root at pcp423960pcs html]# mount -t smbfs -o username="AD\user" //  /mnt/partage
>>27930: session request to failed (Called name not present)
>>27930: session request to 10 failed (Called name not present)
>>[root at pcp423960pcs html]# ls /mnt/partage/
>>01/      5H/      5Q/      6S/      9R/      D0/      J1/      Login/
>>02/      5M/      6H/      6X/      AA/      H3/      J2/      V0/
>>4D/      5P/      6M/      8A/      ADMINNT/ H5/      J4/
>>[root at pcp423960pcs html]# ls /mnt/partage/6H/ACG/Directions/
>>[root at pcp423960pcs html]#
>>before the command, /mnt/partage is empty
>>I'm not at all an expert of Active Directory but maybe it is impossible to see the files of a filer if the source machine doesn't belong to the same ActiveDirectory Domain.
>>And the docs i found about kerberos or samba are about the users of a Samba SERVER, not about the client.
>>Maybe can someone help me, i sincerly hope because i already spent 3 days about this problems.
>>Moreover, i do not want to return to the old web/Php config (which was an NT4 +esayPhp :-/ ... but it worked ...)

Joris De Pooter

More information about the samba mailing list