[Samba] Error when add Samba 3.0.10-1.fc3 to Windows NT Domain

Tony Earnshaw tonye at billy.demon.nl
Fri Apr 1 14:28:26 GMT 2005

John H Terpstra:


>> Next time you come back and write: "I used the official Samba HOWTO
>> Collection to configure and it didn't work".
>> Like that's what I mostly did when I first started with Samba, it
>> works, so I have no particular questions (apart from ACLs, which refuse
>> to work at all), it all works as documented.
> I am adding ACLs documentation to the HOWTO so as to help clarify this
> black-art area. :-) Just give me a few days to get it together.

Actually, the ACL doco in the HOWTO collection is pretty good and
shouldn't need augmenting. Things on my XP workstation work slightly
differently (i.e. buttons appear in other places than described, etc.). I
can modify DOS )?) file attributes, but I can't modify group file ACLs.
The thing doesn't refuse me by saying "Access denied", it just doesn't
modify anything. In short:

1: I can do all the (RHAS3) command line setfacl etc and that works;
2: after Jerry's correction (on the list) to my faulty rpm spec ./configure
parameter, my smbd -b output is as it should be (so Samba here supports
3: The only thing left is, that some part of my smb.conf has to be wrong.
SWAT says that I have "nt acl support", I've ....


IT WORKS NOW! Changing AC Ls from my XP machine works now!

While I was writing this, I hauled all the ACL lines (3 of them) from my
[global] smb.conf section, leaving "nt acl support = Yes" by default And
then it all started working :))) Amazing.

Now I can go about adding ACL directives to each share to see what happens
to individual shares.

Thanks, John!


mail: tonye at billy.demon.nl

More information about the samba mailing list