[Samba] Windows XP - Explorer crashes when I try to open a file ona Samba share

Stuart Highlander fsb at ntwsdb.com
Tue Sep 28 15:33:27 GMT 2004

----- Original Message ----- 
From: "Lenroc" <lenroc at gmail.com>
To: <samba at lists.samba.org>
Sent: Monday, September 27, 2004 11:18 PM
Subject: [Samba] Windows XP - Explorer crashes when I try to open a file ona
Samba share

I am having problems with my samba clients. I am using Windows XP SP1 to
try to connect to a Samba server I have running on my Gentoo Linux server.

Browsing a share works decently well, but I ocassionally have network
problems (the same timeout issue I explain below).

The real problem comes, though, when I try to access a file (either trying
to open it or just right-clicking on it). As soon as I try, Explorer (the
Windows file browser) locks up hard. Eventually, the title bar of the
windows will update itself to say "Not Responding", but the only way out
is to force Explorer to quit and then wait for it to relaunch (or, if I'm
lucky, sometimes I can pull up the Task Manager and start Explorer that

I have checked the logs on my server, and the entries I see are like this:

[2004/09/27 20:43:27, 1] smbd/service.c:make_connection_snum(648) ( connect to service phpws initially as user
lenroc (uid=1000, gid=100) (pid 32369)
[2004/09/27 20:44:28, 0] lib/util_sock.c:read_socket_data(384)
  read_socket_data: recv failure for 4. Error = Connection reset by peer
[2004/09/27 20:44:28, 1] smbd/service.c:close_cnum(837) ( closed connection to service phpws

The first entry corresponds with when I try to access a file. Then it
seems to wait for ~60 seconds before erroring out, then automagically
reconnecting. (I still don't get the file though. Windows just gives up, I

The only portion of my smb.conf that I think is relevant is the following
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

However, even without that line (so, using whatever the defaults are) I
experience the exact same problem.

Based on the error, it does not really seem like a Samba problem, but I do
successfully use this same server as an internal FTP (pure-ftpd), HTTP
(apache), IMAP (courier-imap), and DNS (dnsmasq) server, so if it is a
general networking problem, it's not widespread.

I have also tried mapping the share to a network drive, and using other
programs to open files directly, but I run into the exact same problems.

I have tried 2 different WinXP SP1 clients. I unfortunately do not have
any other breeds of Windows available to test.

Can anyone suggest any further troubleshooting steps I should take to help
narrow down the problem?


To unsubscribe from this list go to the following URL and read the
instructions:  http://lists.samba.org/mailman/listinfo/samba

good morning lenroc,

are the clients and server on the same subnet or seperated by routers?


More information about the samba mailing list