[Samba] Do software raids don't dance Samba?

Adam Tauno Williams adam at morrison-ind.com
Sat Sep 25 18:06:04 GMT 2004

>It seems to me like - at least my - software raid can't dance Samba. I've
> got a box with SUSE 9.1 (Linux datagarden 2.6.4-54.5-default #1 Fri May 7 
> 16:47:49 UTC 2004 x86_64 x86_64 x86_64 GNU/Linux) and I've dld and compiled 
> Samba version 3.0.7-1.1-SUSE. 
> >And as you might guess from the subject, I'd like to use it together
> software raid (levl5)to store this and that. I'm using the default raid 
> software package that gets shipped with 9.1 together with a Highpoint 
> RocketRAID 454 ATA card with 8 disks

If your using a RAID card you are not using software RAID, or maybe you are, but
in combindation with hardware RAID.

>>As I am a Linux beginner, I can't really tell you what version of raid
>>software the box s using. If I run raid0run -V it tells me "mkraid version 
>>0.90.0" and if I run raidstart -V it says "raidstart v0.3d compiled for md 
>>raidtools-1.00.3". Hmmm....
>I'd look at the Highpoint drivers.
>I've been using raid5 with samba-3_0 svn for a couple months now without 

Agree.  Remove the RAID card and use just software RAID, or get a reputable RAID
card.  We've been using Samba on Linux/RAID via both hardware and software(md)
without incident for **years**.

More information about the samba mailing list