[Samba] Do software raids don't dance Samba?

Doug VanLeuven roamdad at sonic.net
Sat Sep 25 03:54:10 GMT 2004

Mike Quest wrote:

>It seems to me like - at least my - software raid can't dance Samba. I've got a box 
>with SUSE 9.1 (Linux datagarden 2.6.4-54.5-default #1 Fri May 7 16:47:49 UTC 2004 
>x86_64 x86_64 x86_64 GNU/Linux) and I've dld and compiled Samba version 3.0.7-1.1-SUSE. 
>And as you might guess from the subject, I'd like to use it together software raid (levl5)
>to store this and that. I'm using the default raid software package that gets shipped 
>with 9.1 together with a Highpoint RocketRAID 454 ATA card with 8 disks connected 
>to it:
>datagarden:/local # cat /proc/mdstat
>Personalities : [raid5]
>md0 : active raid5 hdi1[7] hdh1[6] hdg1[5] hdf1[4] hde1[3] hdd1[2] hdc1[1] hdb1[0]
>      2050671616 blocks level 5, 128k chunk, algorithm 2 [8/8] [UUUUUUUU]
>hdi is on the motherboard's build-in controller as I couldn't convice the box that it 
>should boot from the motherboard, but that's another story. But I hope, that this 
>isn't causing the problem.
>As I am a Linux beginner, I can't really tell you what version of raid software the box 
>is using. If I run raid0run -V it tells me "mkraid version 0.90.0" and if I run raidstart 
>-V it says "raidstart v0.3d compiled for md raidtools-1.00.3". Hmmm....
I'd look at the Highpoint drivers.
I've been using raid5 with samba-3_0 svn for a couple months now without 
On the other hand, I only use one additional IDE card, with one drive 
per channel which means 4 drives.  Nothing fancy, just a SIIG ATA.  
Didn't look to me like multiple ide cards were well supported.

Other than that, I'm running the same level raidtools, old Redhat 9 with 


More information about the samba mailing list