[Samba] Very weird access problems from win2k3 to samba 3.x

Eli eli-list at experthost.com
Fri Sep 24 21:15:43 GMT 2004

Jeremy Allison wrote:
> On Fri, Sep 24, 2004 at 04:22:16PM -0400, Eli wrote:
>> I've got a samba 3.0.5 (I can't get 3.0.6 or 3.0.7 to compile - I'll
>> get to that later) server running and it *appears* to be working
>> just fine. 
>>> From the 2k3 system in question, if I open an explorer window I can
>>> access 
>> the server via UNC just fine, no errors or anything on the Windows
>> side. 
>> On the Samba side though, once in a while I get this in the
>> samba.log file (and I'm sure you've all seen this countless times
>> before): 
>> <snip>
> Is this on Linux ? If so are you using sendfile ? If so
> try setting "use sendfile = no".

Sorry, yes it is on Linux.  No specific distribution - it's a Linux system
I've put together myself.  Kernel is 2.4.26 - if there's any other versions
of things you want lemme know and I can tell you.

I tried use sendfile = no and it didn't seem to make any change either.
Exact same error messages and same behaviour.  I've thought about
recompiling 3.0.5 in developer mode 'cause I hear that spits out more info
in the logfiles, but if there's any way I can just turn on more logging to
maybe get more info, what would be the log levels I'd set and to what? (I
couldn't find any documentation on what all I could do with the logging
setting in Samba since it had been improved to allow multiple settings and


More information about the samba mailing list