[Samba] Very weird access problems from win2k3 to samba 3.x

Eli eli-list at experthost.com
Fri Sep 24 20:22:16 GMT 2004

I've got a samba 3.0.5 (I can't get 3.0.6 or 3.0.7 to compile - I'll get to
that later) server running and it *appears* to be working just fine.

>From the 2k3 system in question, if I open an explorer window I can access
the server via UNC just fine, no errors or anything on the Windows side.

On the Samba side though, once in a while I get this in the samba.log file
(and I'm sure you've all seen this countless times before):

[2004/09/18 02:00:19, 0] lib/access.c:check_access(328)
[2004/09/18 02:00:19, 0] lib/util_sock.c:get_peer_addr(978)
  getpeername failed. Error was Transport endpoint is not connected
  Denied connection from  (
[2004/09/18 02:00:19, 1] smbd/process.c:process_smb(883)
[2004/09/18 02:00:19, 0] lib/util_sock.c:get_peer_addr(978)
  getpeername failed. Error was Transport endpoint is not connected
  Connection denied from
[2004/09/18 02:00:19, 0] lib/util_sock.c:write_socket_data(413)
  write_socket_data: write failure. Error = Connection reset by peer
[2004/09/18 02:00:19, 0] lib/util_sock.c:write_socket(438)
  write_socket: Error writing 5 bytes to socket 24: ERRNO = Connection reset
by peer
[2004/09/18 02:00:19, 0] lib/util_sock.c:send_smb(630)
  Error writing 5 bytes to client. -1. (Connection reset by peer)

I haven't figured out why I get this yet even with all the searching I've
done on the 'net.  I've seen other cases where there were firewalls in the
way of DNS resolution or something to that extent (none of which are an
issue with my setup), however I seem to only get this error when I encounter
the access problem which I'll now try to describe.

The access problem happens if I open up MS Backup, and try to open a backup
set to restore from.  The wizard allows me to browse for the file, so when I
do if I just type in the server name via UNC, it displays the share fine,
but if I try to open the share, I get an Access denied error saying that I
probably don't have the right permissions.  If I check the permissions (and
this is where I've been messing around the last couple of days trying every
combo of Samba settings to see if it makes a difference), It pretty much
always seems to show that none of the users (used to be Everyone then samba
and samba (unix user/group), then I mapped unix groups and it displays
Everyone, samba, and System Operators) had any permissions on it at all.  I
finally used a setting in Samba to give Everyone full access to the share,
yet that STILL didn't seem to fix the problem.

The weirdest part of it out of everything is, if in the browse window I
instead type the full path to the backup set, MS Backup shoots no error at
me and gladly loads the file without any problems.  So it's like I have
access, but don't at the same time?

I've gone through everything I can think of.  I've tried all sorts of
settings and nothing seems to make a difference.  I checked against a Samba
2.x system I have and it doesn't suffer from this problem at all.

Here's my smb.conf (in condensed form from testparm):

        server string =
        interfaces =,
        bind interfaces only = Yes
        security = SHARE
        guest account = samba
        log file = /var/log/samba.log
        max log size = 500
        deadtime = 15
        preferred master = No
        domain master = No
        wins support = Yes
        hosts allow = 127., 197.101.0.

        read only = No
        create mask = 0644
        browseable = No

        path = /mnt/raid/disk1
        read only = No
        create mask = 0644
        guest only = Yes
        guest ok = Yes
        profile acls = Yes

The "profile acls = Yes" thing was what I added to give Everyone full
permissions to see if that'd fix anything, but it didn't.  The share I'm
concerned with is the disk1 share.  There are no homes, but I just kept that
there from a general config file I use.  I know it's not unix permissions
because the path I'm sharing I've ensured has permissions.  We can
create/delete/modify/list all files in the share via MS Explorer, and all
files that are created and such are created with the correct permissions.

I would have tried upgrading to 3.0.6 or 3.0.7 to see if it's just a 3.0.5
problem, but when I compile anything newer, I get so many warnings and
finally an error (esp 3.0.7) in the smbwrapper.  I've even tried compiling
without any options and still I get errors.  Are there any dependencies on
gcc or something for the newer Sambas that would cause this?  3.0.5 compiled
with some warnings here and there which looked scary, but it works (aside
from this one problem of course :P).


More information about the samba mailing list