[Samba] Re: Samba 3.0.3 on FC2: windows machine cannot join domain

Tony Fugere tony_fugere at ncsu.edu
Thu Sep 23 23:15:38 GMT 2004

I'm pretty sure that we have our problems solved by using %m, but I will 
triple check and post results in a few hours. I don't really want to 
mislead anyone into having a six month struggle as I have had with this.


John H Terpstra wrote:


I do not have any proof to contradict your information, however, the source 
code suggests that this advice is perhaps suspect.

The particular module that handles automatic account creation is in 
~samba/source/rpc_server/srv_samr_nt.c and specifically at line 2253.
Here is the very line that does the parameter substitution:

 all_string_sub(add_script, "%u", account, sizeof(add_script));

As you can see, it is the "%u" parameter that is being substituted. Maybe I am 
reading this incorrectly? However, I have performed many hundreds of 
installations and have always used the "%u" parameter - and it has worked.

Given this background I respectfully suggest that we should understand 
precisely what is happening in your situation by examining the samba logs for 
the use of this function give both the "%u" and again with the "%m" 
parameters. You can turn up the debug level on just this module by setting
in smb.conf [globals]:
	log level = 0 rpc_srv:5 sam:5
	log file = /var/log/samba/%m.log
	max log size = 0

Please would test this and report the findings. If our documentation is in 
error I want to fix it immediately.

Thanks so much for your input.

John T.

More information about the samba mailing list