[Samba] Samba, CUPS, or ?

Mark Halegua msh at farsight-data.com
Mon Sep 20 05:48:36 GMT 2004

I've been going over a problem and haven't been able to resolve it.

I think I've narrowed the problem down to Samba, but I could use some advice 
on this.  

A few weeks ago I installed a print and fax server for a client.  I used an 
old PII system with 64 MB RAM, SUSE Pro 9.1, configured to use Samba and 
HylaFAX.  There are 8 client workstations running Window 98 SE (most of the 
systems are PII and PIII, so Win98 is the best solution for now).

After getting the kinks out it worked perfectly for about 1.5 weeks.  Then, 
one of the people used a different system and sent a print job from a DOS app 
through a captured printer port.  The printer driver was for a Brother 
HL-1440 laser, but the job was going to a HP LaserJet 5Si (the printer 
connected to the print/fax server).

It spewed garbage until one of the users finally went to the printer and 
cancelled the job.  Since then most of the users can't print from either 
Windows or DOS apps to the 5Si.  And sometimes some of them can, but they 
lose the capability later.  Sometimes they get an error message "invalid 
access code" or a system error.

The reason I think it's Samba is, none of the systems see the printer in 
network neighborhood.  They DO see the system, a couple of folders I've made 
available for admin and testing purposes, and the pdf printer Samba has, but 
no longer see the 5Si, which they should see as hp_laserjet5si.

I've checked to see, through ldd, the proper linking of Samba to the required 
printing and CUPS libs.  They're there.  The printer works properly from the 
server itself from the command line and from within scripts (the client 
wanted the faxes to print automatically upon receipt, and they continue to 
print out properly).

I looked in /var/spool/samba and I saw a number of files, with the 
usernames of the people who submitted the jobs, and the group users.  But all 
the files were 0 bytes.  When I tried to print one from the command line, it 
gave a stdin nothing found message (approximate message, I forget the word 
for word).

If it was one system, I'd guess a windows problem.  But the browse and 0 byte 
for printer jobs is .... unusual.  I've never seen Samba do this before.

I've reset the server (not necessary, I know, but just in case) and manually 
restarted the Samba (smbd, nmbd) daemons, the windows systems still don't see 
the printer.  

To add to the issue, a file server set up a couple of years ago with SUSE 7.3 
Pro is at Samba 2.2.  Thinking this may be a conflict between Samba versions 
on the same network, I shutdown the file server, shutdown and restarted the 
print/fax server, and restarted the windows workstations.  This didn't help.

As a last try, thinking the print/fax server itself may have some problem, and 
to eliminate it as a variable, I set up a different system and set it up as 
the first print/fax server and the same thing happened.

I'm totally stumped on this.

Any suggestions would be appreciated.



Here is the smb.conf file:

# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SuSE
# Date: 2004-04-06
        workgroup = WORKGROUP
        interfaces = eth0
        bind interfaces only = true
        load printers = yes
        printing = cups
        printcap name = cups 
        printer admin = @ntadmin, root, administrator
        map to guest = Bad User
        comment = Home Directories
        valid users = %S
        browseable = No
        read only = No

        comment = a place for common stuff for all users
        writeable = no
        browseable = yes
        read only = yes
        comment = All users
        path = /home
        writeable = Yes
        inherit permissions = Yes
        veto files = /aquota.user/groups/shares/
        comment = All groups
        path = /home/groups
        writeable = Yes
        inherit permissions = Yes
        comment = PDF creator
        path = /var/tmp
        printable = Yes
        print command = /usr/bin/smbprngenpdf -J '%J' -c %c -s %s -u '%u' -z 
        create mask = 0600
        comment = All Printers
        path = /var/spool/samba
        public = yes
        guest ok = yes
        writable = no
        printable = Yes
        create mask = 0600
        browseable = No
        printer admin = root, @ntadmins

        comment = received faxes
        path = /var/spool/fax/recvq
        create mask = 0600
        browseable = Yes
        read only = Yes

        comment = Printer Drivers
        path = /var/lib/samba/drivers
        write list = @ntadmin root users guest
        force group = ntadmin
        create mask = 0664
        directory mask = 0775

More information about the samba mailing list