[Samba] could not fetch trust account password for domain

Dave Wilson dave.lee.wilson at gmail.com
Fri Sep 17 17:10:02 GMT 2004

Hi all,

I am a samba rookie with a problem.  I have replaced an old server
with a new server, and copied over the original samba config which was
for samba file but the new server has samba 3.0.5 while the old
version was 2.0.7.  I had problems connecting to samba, so I tried
using the supplied default config file and then migrated the original
settings to the new file.  problems still persisted.  We have a w2k
pdc using AD and we want this samba file server to be in it's own
workgroup or domain.  The original global settings were:

        wins server = a.b.c.d
        dns proxy = no 
        encrypt passwords = yes
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        preferred master = no
        password server = server_pdc another_machine_no_longer_in_use
        security = domain
        ssl ca certfile = /usr/share/ssl/certs/ca-bundle.crt
        workgroup = XYZ
        server string = XYZ File & Print
        netbios name = vault
        log file = /var/log/samba/%m.log
        load printers = yes
        netbios aliases = intranet cvs

when I try to connect to this samba server from a windows xp
workstation or from another linux box, the log file has the following
error message:

[2004/08/23 10:33:36, 0] auth/auth_domain.c:check_ntdomain_security(284)
  check_ntdomain_security: could not fetch trust account password for
domain 'XYZ'

I've tried looking at the samba ml archives and the docs, but can't
figure out how to solve this problem.  I'm pretty inexperienced with
smb and windows domain issues, most of my experience has been very
simple setups.  Any help is much appreciated.


More information about the samba mailing list