[Samba] large file support >4GB (nt4.0sp5->smb3.0.6-suse9.0-kernel2.4.21)

c_gensler at icaros.de c_gensler at icaros.de
Wed Sep 15 14:52:10 GMT 2004

I am unable to copy a file larger than 4GB to a samba fileserver!

My config:
- client is windows nt 4.0 sp 5 (I tried sp 6 without any change, I tried
w2k, too)
- server (now) is samba 3.0.6 on suse linux 9.0 kernel
- share is on a reiserfs hardware-raid array with plenty of free space
(explorer correctly _shows_ >500 GB, mapped as ntfs drive)

Every time I try to copy a large file > 4GB to samba, nt explorer seems to
be busy for some (10-30) seconds without reasonable data transfer (switch
leds rarely blinking). As soon as data transfer seems to start (I tried it
with a 3 GB file which worked fine), nt explorer shows a message "<file>
cannot be copied, reached end of file (EOF)" (translated from german error
message, so don't take literal!)

There were some hints in the newsgroups but all say this should be fixed
since 2.2.x, so now I use 3.0.6 and the problem did not disappear.

My odyssee from samba 2.0.x by 2.2.11 to 3.0.6 and hours of reading this
group end up now here in another request for this. I cannot help anymore,
this problem drives me nuts.

So, is anyone here to solve this? More infos and log files are available,
but there's too much to post it unrequested!

Nowadays (2004!) it should be possible for samba to handle files > 4GB,
shouldn't it?

Many thanks in advance!

chris at gensler.to

More information about the samba mailing list