[Samba] file context menu takes for ever with 3.0.6,bothserne tand suse

Dragan Krnic dkrnic at lycos.com
Thu Sep 9 08:35:02 GMT 2004

A sort of wrap-up coda to the discussion off this thread:

>>>>> I've tested SerNet's ans SuSE's versions of Samba 3.0.6
>>>>> on a test member server. Joining domain, attaching share
>>>>> all works but if I right-click a file, the context menu
>>>>> takes for ever to pop up. If I select Properties, it
>>>>> takes even longer until the dialog box appears.
>>>> Are these XP clients?
>>> I should have mentioned it.
>>> No, the problem affects both XP and w2k
>>>> Try setting "large readwrite = no" (be sure to restart 
>>>> the client on a new smbd or you won't know for sure) 
>>>> and see if that changes the behaviour. I have several 
>>>> systems with the same exact issues you describe. 
>>>> Changing that value helped me...I'm hoping Jeremy can help 
>>>> me understand why in an email I sent to samba-technical.
>>> Thanks, Bill. I'll try both your suggestion and Jeremy's 
>>> sendfile hint first thing in the morning.
>> Setting "large readwrite = no" has a dramatic impact but not the
>> one desired. After mounting the share the icon was that of a dir
>> instead of that of a shared drive. Clicking on it turned the cursor
>> to an hourglass for a long time and after about 30s there was the
>> correct icon for shared drive but also a pop-up error message:
>>    "X:\ cannot be accessed.
>>     The network name is no more available."
>> On the other hand setting "use sendfile = no" solved the problem
>> entirely.
>> Thank you Jeremy
> I'm replying off-list. I'm glad to hear the sendfile worked for you,
> but I'm curious, do you have TCP_NODELAY in your socket options? 
> and what are the values for SO_SNDBUV and SO_RCVBUF? what does 
> "no -a" show for your tcp send and receive bufs. I know Suse is 
> different from AIX, I'm just trying to understand by how much ;-)

socket options include SO_KEEPALIVE IPTOS_LOWDELAY and TCP_DELAY
on my systems.

What command is meant by "no" as in "no -a"?
I don't find it on my Linux.

> did you try "large readwrite = no" with sendfile on or off? 
> I'm just really curious because my system just FLEW after that 
> change, but I have TCP_NODELAY SO_SNDBUF=262144 SO_RCVBUF=262144 
> and have the "no" options tuned accordingly.

I dealt with both modifications separately.
I'll give it a try jointly + your 256k buffers
just to see if it makes a dent. But "no" options
can't be tuned on my system. Must be an AIX-specific
utility, something like "network options", which
one sets in different sysconfig files on Linux ...

... Yes you're right. Both options suppressed, 
"use sendfile" as well as "large readwrite",
solved the problem just as well as "don't use sendfile"
alone did, except it appears to be markedly
prompter. I need more tests to be sure about
the latter.

> AIX does not have sendfile.
> When I turned large r/w off, my system stopped sending in 32KB 
> chunks and returned to the "max xmit=16644" default and then my 
> clients were quite happy.

Has anyone else been experimenting with large SND and RCV BUFs ?
What are the experiences? 
Or drawbacks?

More information about the samba mailing list