[Samba] Samba 3.0.6 Problems w/AD and Kerberos

S Murthy Kambhampaty smk_va at yahoo.com
Wed Sep 8 23:45:21 GMT 2004

I had some of the symptoms described in the thread at:
which appear to have been solved by changing the value
of the "valid users" parameter from '@Domain Users' to
@"Domain Users".

It appears that samba 3.0.6 got very picky about how
the "valid users" parameter value is defined.  In my
Fedora Core setup (samba 3.0.3 from FC2), I originally
had >valid users = '+Domain Users' which worked with
3.0.3 (and 3.0.4 on my Redhat 8.0 boxes).  Upgrading
to 3.0.6, this stopped working.  It worked when I
changed it to valid users = @"Domain Users".  However,
editing shares in swat reverts this value to '@Domain
Users' and it stops working.  Moreover, downgrades to
3.0.5 seem to change this value to '@Domain, Users'
(note the comma) and that does not work with 3.0.5
either (hand-editing to get rid of the comma "solves"
the problem).  

So, now I do have samba 3.0.6 working with ADS (Win
2k, SP4) and kerberos 1.3.4 (fc2's latest update) and
have to remember not to edit shares with swat.  I hope
this is not just one of those flash-in-the-pan symptom
and cures, which it sure sounds like.  However, I have
been able to replicate the behavior I've described ...


Do you Yahoo!?
Yahoo! Mail Address AutoComplete - You start. We finish.

More information about the samba mailing list