[Samba] Win2K and Samba 2.2.5

Chris Roubekas croubekas at loutrakifm.gr
Mon Sep 6 13:36:02 GMT 2004

Dear all,

    I have a SuSE 8.1 Installation running on a box and
mixed windows versions on clients doing domain loggons
etc on the SuSE8.1 box (I have activated Samba on it
and all works just fine!).
    One of them has Win2K and it is running a software that plays
MP3s from the SuSE server on a 24hour basis (that is non-stop).
    For the past few months, the Win2K client will show an
unexpected error stating :"There is a problem on your hard disk
or the network" which causes all MP3 playing to cease. 
At that point, I have to terminate the program and restart it
so it can continue. This doesn't make any sense since
all other clients on the network can play those mp3s without
any problems, however they do not play on a 24hour basis.
    I have checked for bad clusters etc on the SuSE machine, none
found. I have checked the MP3s which caused the system to stop
but they are absolutely fine and I can play them on any other PC
including the one that stopped!!

    In addition, whenever something like this happens, I get the following
error in the /var/log/messages log file:

Jul 20 18:01:41 mp3 smbd-classic[18241]: [2004/07/20 18:01:41, 0] lib/util_sock.c:read_data(436)
Jul 20 18:01:41 mp3 smbd-classic[18241]:   read_data: read failure for 4. Error = Connection reset by peer

Also I do not seem to get any errors in the /var/log/samba/log.smb or log/nmb files
which I wonder why....

I have tried to figure out what the hell that error means and I cannot find
anything for the life of me!!!

I even changed my network cards on both (client and server) still nothing!
The error continues to appear on the client and the server.
It does not appear on a periodic interval (i.e. every 6 hours or something
like that) so I cannot seem to trace it in any way!!!!
I even re-installed my entire SuSE from scratch and fully patched it from
fou4s and still no results! The only thing that I have not done yet is to upgrade
it to Samba 3 (in case the Samba-Team has fixed something like this
for which I have no idea since I am a very new linux user).

Please, please, please help me with this one! It is driving me absolutely

Thank you in advance for your time and effort

Kind Regards,

PS : The client that has these problems is running Windows 2000 SP:2.

More information about the samba mailing list