[Samba] file open problems

Erik Thiele erik at thiele-hydraulik.de
Mon Sep 6 07:38:17 GMT 2004

To tell more exactly where the problem lies, I did the following:

1) create an empty share on both my NT4.0 server and my samba server.

2) perform the software installation on both NT4.0 and samba share. the
NT4.0 runs through, the samba fails at some point.

3) do the installation again. because the samba share based install
stops very early now. directly at the first file he wants to do. the
file already exists from the prior install of course. also redo the
installation on the nt share.

4) i dumped step 3) with ethereal. what you see there is the beginning
of the session. the ntserver based session continues but is clipped
here. but the samba based session ends where the log ends. he then shows
a popup window saying there are not enough rights or diskspace free.

the logs are on http://www.thiele-hydraulik.de/sambaproblem/

i hope we will find some solution to this as it confuses me very much.
If not i have to stick with the NT server, which i don't like too much.

it's interesting to do a side-by-side diff of the two logs, but i am not
enough a SMB expert to find the problem here :) but there must be some
point that convinces the software of some problem i do not know of yet.

cya thx

On Fri, 3 Sep 2004 16:09:00 +0200
Erik Thiele <erik at thiele-hydraulik.de> wrote:

> Hi. am running a samba server version 3.0.5 on a gentoo linux machine,
> kernel 2.6.7-gentoo-r8.
> the client is a windows XP machine.
> the PDC is a windows NT 4.0 machine.
> this is my smb.conf:
> [global]
>         workgroup = FOO
>         hosts allow =
>         local master = no
>         log file = /var/log/samba3/log.%m
>         os level = 0
>         preferred master = no
>         security = domain
>         username map = /etc/samba/smbusers
>         wins server = ntserver.firm-internal
>         password server = ntserver.firm-internal
>         load printers = no
>         domain master = no
>         bind interfaces only = yes
>         interfaces = eth0 lo
> [tshare]
>         comment = Test Share
>         path = /tshare
>         read only = no
> the tshare directory is empty. i am logging into the XP machine as
> "Administrator". it gets mapped to user root. i can verify that by
> creating files with windows explorer and having a look at them on
> linux server.
> I am installing some proprietary commercial software we bought. it
> wants to put some of its data on network. if i supply this network
> drive from an empty share of my NT 4.0 server, all works. if i supply
> this network drive from my linux server, many files get installed and
> after a while he sais he cannot open a certain file on the network
> share. he asks if i have enough free space (some gigabytes are free)
> or if i have enough rights. that file has already been created by the
> setup program itself. i can open it in windows explorer. i can write
> there, save, erase, whatever. it works.
> the whole issue seems to me to be some race condition. i had a running
> printjob on the samba server over slow unoptimized parallel port, then
> suddenly the setup ran through. but it seems not be reproducible. now
> each time he stops on the same file.
> please enlighten me about where the problem could be. the setup
> program is a "Wise installation assistent", probably this should
> clarify what kind of windows setup tool it is. I am not a windows
> expert.
> if i erase all files on the network share prior to the next attempt to
> run the setup tool, then the error will always be at the same file.
> but if i instead do not erase the files, he will make an error on the
> first file he wants to write to (which already exists from last
> setup). i verified that it is the first file by watching with ethereal
> network sniffer. he asks about information on the file, receives it,
> closes the file and makes error box.
> i tried to disable oplocks, and level2 locks. didn't change anything.
> i tried to fiddle around with name mangling, didn't change anything.
> help :)
> Erik

More information about the samba mailing list