[Samba] Problem Enumerating AD users

George Trigg george at gt-enterprises.co.uk
Sat Oct 23 15:45:41 GMT 2004

I am trying to create a samba server a a AD member,  I have set up security
= ads.  I have made the necessary changes to nsswich.conf and krb5.conf.
wbinfo returns a list of user & groups and also maps sucesfully between
username and SID and vice versa.
I have tried upgrading the fedora supplied binaries to the ones from the
redhat mirror.
However when doing a getent passwd I am only returned the local unix users
and I get the following error in the syslog. 
Oct 23 16:23:40 ecto winbindd[2089]: [2004/10/23 16:23:40, 0]
Oct 23 16:23:40 ecto winbindd[2089]:   idmap Fatal Error: UID range full!!
(max: 20000)
The following is the output from net ads info 
LDAP server:
LDAP server name: egon
Realm: EAL.LED
Bind Path: dc=EAL,dc=LED
LDAP port: 389
Server time: Sat, 23 Oct 2004 16:39:30 GMT
KDC server:
Server time offset: -1
Below is my smb.conf file
   netbiosname = ECTO
   workgroup = EAL
   server string = ESL File Server
   hosts allow = 192.168.1. 192.168.11. 192.168.12. 192.168.14.  127.
#   printcap name = /etc/printcap
#   load printers = yes
#   printing = cups
   log file = /var/log/samba/%m.log
   max log size = 100
   security = ADS
   encrypt passwords = yes
   socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
   interfaces =  
   remote announce = 
   local master = no
   os level = 33
   domain master = no 
   preferred master = no
   domain logons = no
   wins support = no
   wins server =
   wins proxy = no
   dns proxy = no 
   preserve case = yes
   short preserve case = yes
   default case = lower
   case sensitive = no
   winbind enum users = yes
   winbind enum groups = yes
   winbind separator = +
   idmap uid = 10000-20000
   idmap gid = 20000-30000
   winbind enable local accounts = no
   realm = EAL.LED
   template shell = /bin/false
   winbind use default domain = yes
   password  server =
#============================ Share
   comment = Home Directories
   browseable = no
   writable = yes
Any pointers in the right direction that anyone can offer I'd be really
grateful.  I've tried everything I can think of!
Thanks in anticipation 

More information about the samba mailing list