[Samba] Group problems and at my wits' end!

Misty Stanley-Jones misty at borkholder.com
Mon Oct 18 18:31:04 GMT 2004


I posted before that I was having problems with root showing up as a member of 
GID 1001 which I had set to 'engr'.  Someone sent me an email saying that 
this was because gid=0 was also trying to map to RID=1001.  Well, ok.  So I 
made an explicit mapping from gid=0 to rid=0.  I don't want "Domain Admins" 
to also be gid=0.  It seems like it could cause more damage.  So I have a 
grup mapping from gid=512 to rid=512 (Domain Admins).  It always worked 
before.  Everything worked except for the weird problem of root putting 
itself into rid=1001.

Well, now after all of my messing around and changing things, I can't even 
join a Windows 2000 workstation to the domain.  I get "The user name could 
not be found."  I am using 'root' and the password for root.  This same 
username and password works just fine with smbclient command which tells me 
that root is still in the database.  And root still shows up as a member of 
Domain Admins.  

The funny thing is that I even restored the LDAP db from before I started 
messing with things and even then, it doesn't work.  Something has happened 
to my root user in Samba, from me messing around with mappings, and I don't 
know what it is.  Any help is greatly appreciated in debugging.  I have 
looked at the level 10 debug log and I get nothing useful.  The closest thing 
I see is:
  UNIX token of user 0
  Primary group is 0 and contains 0 supplementary groups

More information about the samba mailing list