[Samba] smbfs mount issues

Culver, Chuck chuck at sussex.tec.nj.us
Wed Oct 13 18:11:50 GMT 2004

I am having a similar problem on a Domain.

The problem only seems to be when mounting a share located on a Windows
2003 server.

My problem is this:   I run the mount command.  It completes without
error.  However, the mount path disappears.

In your example, /path/to/mount/dir would be mounted, but the "dir"
would disappear from view.

If I open a terminal, SU, and then ls -la /path/to/mount
It will not show anything at all.

If I run unmount the share, the folder reappears.

This used to work on an older version of Samba.. like 2.28 or early 3.
Now I am running 3.0.7-2 on Mandrake 10.1.

The stranger part is, I can "preview" the contents with SMB4K or LAN://
but once it is mounted....

-----Original Message-----
From: samba-bounces+cculver=sussex.tec.nj.us at lists.samba.org
[mailto:samba-bounces+cculver=sussex.tec.nj.us at lists.samba.org] On
Behalf Of Jason Pirok
Sent: Wednesday, October 13, 2004 2:03 PM
To: samba at lists.samba.org
Subject: [Samba] smbfs mount issues

This problem began a couple months ago with my new install of (you
guessed it) XP sp2.  Now, when i mount a share from the xp machine to
my debian box, everyone, including rot, gets a permission denied
trying to ls the dir.

I've read posts about switching to cifs, but that has opened a whole
new can of worms.  I'd just like to see smbfs mount my shares properly
the way they used to.

My version of samba is 3.0.7-1 according to dpkg on debian unstable.  
the mount command is

mount -t smbfs -o
//host/share /path/to/mount/dir

I've done lots of look ups on google regarding many combinations of xp
smbfs and the problems encountered to no avail.  I'm at wits end and
don't know what else to do.


To unsubscribe from this list go to the following URL and read the
instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list