[Samba] linux server freezes on large file transfers

Monty poison at bellsouth.net
Tue Oct 12 22:52:50 GMT 2004

Still no progress.  Just tried to transfer 1.3GB fle and my box locked up. 

I am running MD 10 (Community) as a file server on a Shuttle SB61G2. This 
setup worked very well under Mandrake 9.2 however, everytime I try to copy 
files larger than say <550 ~650MB using MD 10, my linux box freezes and must 
be rebooted. I can FTP the same file(s) perfectly fine to other PC 's on my 
home net.  Small volumes of files work fine as well as ISO images, the box 
seems to lock up only after it passes some type of treshold treshold.  I am 
not sure what to do here.  I have installed of the latest SMB packages for MD 
10.  The problem still persists.

Is there some config parameter that I must change? 

#======================= Global Settings =====================================
        log file = /var/log/samba/log.%m
        smb passwd file = /etc/samba/smbpasswd
        load printers = yes
        passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n 
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        encrypt passwords = yes
        passwd program = /usr/bin/passwd %u
        dns proxy = no
        server string = Samba Server
        printing = cups
        unix password sync = Yes
        workgroup = Southpark
        printcap name = lpstat
        security = user
        max log size = 500
        use sendfile = no

 comment = Home Directories
 browseable = no
 writable = yes

More information about the samba mailing list