[Samba] Removing a Point And Print printer

Martin Zielinski mz at seh.de
Fri Oct 8 13:45:33 GMT 2004


I assume, that the BusinessJet is an ink printer.
Many of the Deskjet drivers need a device mode to function.
Try setting "default devmode = yes" in your smb.conf.

To remove your driver you could use the Windows Gui.
(The remove button in the Drivers tab on your samba server).
Completely removing your printer is more complex. It should be enaugh to 
remove it from your spooler and to restart samba (remove the driver bindings 
before that).
If you want, you can look at the "nt*.tdb" files, to see, what remains.


On Friday 08 October 2004 14:47, Stanley Tim wrote:
> I have a Samba 3.0.4 server that has several point and print printers which
> are functioning just fine.
> I have added another printer, an HP BusinessJet 1100d, and attempted to
> load the drivers on the Samba server for that printer (for WinNT, Win2K and
> WinXP). However, now, when attempting to check the properties of that
> printer from a WinXP client (pre SP2) I only get an error and the
> properties box will not display. (Error is Function address 0x60649f55
> caused a protection fault.)
> I simply removed that printer, and attempted to install it again. But, I
> continually get the same error.
> I tried removing the driver files associated with that printer via the
> PRINT$ share, and loading the drivers again. But, that didn't help.
> One thing I noticed, if I check the properties of a working printer, and
> view the drivers available on that server, the BusinessJet printer is still
> a choice, even though I've removed those files. So, I'm wondering if there
> is a file in Linux/Samba that maintains a list of those drivers which I can
> edit?
> Any help on completely removing a PointAndPrint printer would be greatly
> appreciated.
> Thanks,
> Tim Stanley

Martin Zielinski                       mz at seh.de
Software Development
SEH Computertechnik GmbH     www.seh.de

More information about the samba mailing list