[Samba] Re: Can join domain; can't logon

Igor Belyi sambauser at katehok.ac93.org
Fri Oct 8 03:11:44 GMT 2004

Chris St. Pierre wrote:
> An update:  I managed to get a domain entry added to my LDAP directory.
> Still got the same error.  Googled for it; found out that I had to put
> my machine trust accounts in ou=people instead of ou=machines.  Did
> so.  Still get the same message from Windows:
>>>>"The system cannot log you on to this domain because the system's
>>>>computer account in its primary domain is missing or the password on
>>>>that account is incorrect."
>>From Samba, it's the same old thing:
>   get_md4pw: Workstation GUINEA-PIG$: no account in domain
> What the heck does this mean?  How can I fix it?  Does Samba just hate me?
> I've attached the section of the smbd log that appears to pertain to
> the immediate problem.  Any insights you can offer would be greatly
> appreciated.  Thank you.

Verify that sambaSID of your GUINEA-PIG$ contains SID of the Domain 
(sambaSID field of the sambaDomain entry or result of 'net getlocalsid' 
which should be the same).

And yes, I can take a look at your Samba log. Note, attachments don't 
get through when sent to this list.


More information about the samba mailing list